Testing Needed - AUDIO_CLASH_SUPPRESSION_LEVEL

I’ve been working with @profezzorn to address the false clashes from speaker vibrations and we have a potential solution but need more testing.
I didn’t actually have any sabers that exhibit this behavior but I was able to replicate by leaving the bottom half of a hilt off and lowering the CLASH_THRESHOLD_G for one of my sabers so I used it to test. Now we need to have users who’ve actually had this issue to help test and prove it out.

Baseline:

POC (Test 1):

I have set up a fork with the changes for testing. Go to this page and click the green “Code” button, then select “Download Zip”

There is a new define that lets you set the suppression level for audio

#define AUDIO_CLASH_SUPPRESSION_LEVEL 20

The range for this define is 1 ~ 50 with 1 having almost no suppression for audio and 50 being really high suppression (although the highest I needed during testing was 20 to get desired result).

This define works in conjunction with your CLASH_THRESHOLD_G and to some extent your VOLUME, so users can also use a lower suppression level to be able to increase the volume or lower the CLASH_THRESHOLD_G and increase the sensitivity of the saber.

As a start point my test saber these were the config values I had (although I had to try to recreate this issue so users will need to determine the “Goldilocks” values for their saber:

#define VOLUME 1800
#define CLASH_THRESHOLD_G 3.0
#define AUDIO_CLASH_SUPPRESSION_LEVEL 20

The higher the AUDIO_CLASH_SUPPRESSION_LEVEL the lower you should be able to set CLASH_THRESHOLD_G, you may also be able to increase the VOLUME and not get false clashes but you want to be mindful of what your speaker can handle so you don’t damage the speaker by setting volume too high.
I typically change CLASH_THRESHOLD_G by either 0.25 or 0.5 increments and the AUDIO_CLASH_SUPRESSION_LEVEL by 5s to find the right balance.

I would recommend testing on loud, bassy fonts and run through your accent swings, quotes, force, tracks as those were the sounds that seemed to cause the most false clashes for me. Some fonts and sounds are more likely to trigger false clashes so you’ll want to find the config values that handle everything while still letting you trigger actual clashes as usual.
Note if you set the AUDIO_CLASH_SUPPRESSION_LEVEL too high it will become very hard to trigger any clashes so start around 20 and adjust up or down to determine the best level.

Please reply to this thread if this resolves your issue of false clashes from sounds or if it doesn’t post the values you’re testing so we can see if adjusting helps.

4 Likes

Hey Fernando. Been playing with the new feature so far pretty good. Now if I decide to go all the way up to 50 on my 89 sabers Vader hilt cause it is nasty and loud, will it effect the clash or blaster effects not to work or just not give anymore false clashes blast etc? Let me know thank you.

1 Like

If you make the AUDIO_CLASH_SUPRESSION_LEVEL too large, clashes will be difficult or impossible to trigger when sound is playing.

1 Like

What best in solution then if sound is basy reduce speaker volume And increase the audio clash suspension from 20 to let’s say 30?

Try playing with the filter cutoff as well. Might not even need much.

Sorely needed it for my Korbanth Darksaber because owing to poor design, the chassis sits too far up which prevents a solid grip by the retention screw on the blade. In addition, the 28mm SO Dark Side speaker sitting so close to the proffieboard, with bassy Darksaber fonts, definitely caused a lot of false clashes even with #define CLASH_THRESHOLD_G at 6.0 which then means I really have to hit someone hard with a very sharp pointed blade to get a clash effect.

With the new feature, I’m at CLASH_THRESHOLD 2.5, with #define AUDIO_CLASH_SUPPRESSION_LEVEL 25. Clashes trigger without having to bruise or cut myself and so far no false clashes (knocks on wood).

1 Like

I would test different combinations of clash threshold, volume, audio suppression to find what works best. It will really vary a good amount for each saber.

As noted you can also try

#define FILTER_CUTOFF_FREQUENCY 100 
#define FILTER_ORDER 8

Since I don’t have any sabers that exhibit this I haven’t tested all possibilities so I gave some starting points but it will be up to each user to find what works best for their specific saber.

Ideally, you want the saber to react to all physical “hits” but not have false clashes from loud sounds or hard swings (unless you hit something). Once you’re able to eliminate false clashes you can still fine-tune by adjusting all the defines together.

1 Like

What are the difference between #define FILTER_CUTOFF_FREQUENCY 100
#define FILTER_ORDER 8 if you don’t mind me asking? Secondly where in the config file does the two sit next to where Audio clash suppression is?

info on those defines can be found here, scroll down to ProffieOS 6.x section:

The order of defines doesn’t really matter in your config as long as they are present at the top, for organization you can group together but it’s not required.

This is a great addition to the repertoire of available defines. I had a saber that needed this BADLY and the Clash Threshold I had to set was too high, so I was forced to keep the volume regulated. Looking forward to testing on the next saber presenting false clashes at high volumes.

Thanks @Fett263!

:call_me_hand:t2: Thanks bro.!

As soon as we get back home I’ll start in w testing. The other defines changing the motion sensor value or clash range only made the saber seem to act more latent so I think you’re onto something.

Edit: Unrelated idea question removed.

Huh? So you haven’t tested the solution I spent my time on but you want me to look at something else. This thread is about testing a solution that is already developed, if you want to chase something else do it in your own thread. This is the exact opposite of helpful.

I was merely asking as a reference to clarify something that was brought up. No detour or malice intended.

Unrelated to the topic and unnecessary with current solution

Hey Fernando.! I’ve added the #define FILTER_CUTOFF_FREQUENCY 100 and the
#define FILTER_ORDER 8 and now get a speaker shut off when I make swing. But when I deactivate then turn on again then comes back on the speaker. Strange.!

I’ve never needed to use, maybe @profezzorn knows why.

Maybe this should become its own thread to troubleshoot.

This doesn’t make any sense. All those defines do is affect the frequencies allowed to pass, filtering out low end bass. The alteration should be mostly indistinguishable to the ear, especially with small speakers, other than sounding clearer with less distortion at louder volumes. There’s nothing that would cause a speaker to “shut off” completely by having these defines active unless your sound is comprised of nothing but frequencies ~90Hz and below.
Maybe a video comparison?

1 Like

so I ran it again didn’t shut off. maybe had to cut power with kill switch and turn back on again. I don’t it was a stange situation. it was fine but if coms to that again, ill post a video.

question the #define FILTER_CUTOFF_FREQUENCY 100 and the #define FILTER_ORDER 8 did have to make any adjustments to it or did kept it the same if adjusted what value would I need to go up or down? let me know thank you.!