Which Proffie Components Drive the OLED?

Got an OLED that was working fine but has suddenly decided to just show random pixel shash. It still times out correctly, but that’s the only thing that’s right about it.

All wiring and joints look sound and config hasn’t changed. Done the usual cleaning round the back of it with a toothpick, but it’s pretty inaccessible. Also reflowed the joints at the board, but I knew it wasn’t going to be that as they were all good. Shash remains regardless of whether the SD is fitted or not. Have tried re-uploading the config but no joy. I also tried loading a super-basic one blade config with the oled active (in case accent LEDs were messing things up) but again it’s made no difference.

It’s going to be a bit of a mission to replace the OLED on this hilt, so before I resort to that, I thought I’d check first whether there is some component on the Proffieboard related to oled function that can pack up, and if so, is there any way to test it or replace it?

Proffiboards use the I2C bus to talk to the oled. Apart from the CPU itself, there are only two 2.2k pullup resistors needed to make the I2C bus work. However, if if the I2C bus didn’t work, the expected result wouldn’t be random bits on the display, it would be black.

If you still want to make sure that the I2C bus is working, you can check that the gyro and acceleration is working properly, since those are also hooked up to the I2C bus.

My conclusion is that you need to replace the display.

Thanks Prof. I feared as much.
Just my luck to have my first oled hardware failure on one of the more complex chassis around that will have to be largely torn apart to replace it. :pensive: Dark forces must surely be at work! :confused: LOL!

Anyway thanks for clarifying. Before I start dismantling, I’m gonna give it a blast with a decent air duster (mine’s run out - just ordered another) in case some stray debris is sitting on the back on the screen and shorting some contacts on the bit that can’t be accessed at all. I don’t hold out too much hope, but you never know. It just seems strange that it’s a hardware thing, as more often than not, problems turn out not to be hardware in my experience. :confused:

I just stumbled on this thread:

Unfortunately no resolution is given, but it occurs to me that if the guy’s oled screen only worked with a blade in, could it be that the oled wasn’t happy with a full 3.3 volt power supply, but fitting the blade served to somehow drop the voltage to the oled screen slightly, thus making the oled work?

As mentioned I’m exploring all avenues. In my case I’ve checked the 3.3 volt pad which is all correct, and I unpicked all four oled wires from the Proffie and connected them to my known oled test rig (thus bypassing this entire install and effectively connecting the screen to another build) but no change. Which suggests it is indeed the screen that’s faulty.

But maybe simply adding a resistor to the VCC wire to drop the voltage to, say, 2.8 volts might help? Unfortunately I can’t find any power specs for these screens, so I don’t know what their preferred voltage is. But at this stage it’s worth a shot. Will report back.


Just tried the resistor thing - first 10 ohm then 47 ohm - but no difference. :pensive:

So it looks like it will have to be the full tear down and replacement. :confused: That said, I’ve figured out a way of doing it with only a partial tear down, which is better, but still annoying.

The Force giveth and it taketh away.
C’est la vie.
Chin up and crack on.

How “accessible” is the screen itself? I can’t promise this will help but have ya tried the old calculator screen test and put a little pressure on the screen (readout) to see if anything starts working again? Maybe with a q-tip or blunt wooden stick type of tool. It sounds silly but this trick may or may not indicate hidden damage in the unit itself (like if the hilt was dropped etc.) if the screen starts to partially work again.

Thanks Rogue.
Yeh, I did try stuff like that, but the screen itself was displaying pixels, but just random ones - not anything related to the data that was being sent. So it wasn’t a display thing as such, more a data/electronics thing.

However the good news is I have two of these exact same hilts to build for different people, so I was able to use the individual chassis parts on the unbuilt hilt to figure out an exact procedure for getting to the buried screen on the finished hilt and replacing it. Did the job yesterday and amazingly it went even better than I was expecting. ( :smiley: It was nice to win one for a change! LOL!). So have now managed to replace the offending screen and all is working well.

The bad news is I never got to the bottom of what the fault was, and the old screen got cracked in the process of extracting it (as it was glued in) making any meaningful post mortem impossible.

But anyway, all sorted now and with less trauma than I was expecting. :slight_smile: