WebUSB problems

Have had issues getting web-usb to work. I have selected “serial-webusb-mass storage” and “erial-webusb” in Proffie OS with the same config file attached. (this connection is over usb) As you can see chrome is recognizing the board but after I select “proffieboard” the page stays blank. Am I missing something or is this an issue someone else has experienced?

kylo_ren_v1.h (17.8 KB)

This was in the wrong thread, so I moved it.

1 Like

sorry about that

Several questions:

  1. Does it help if you eject the drive first?
  2. Does it work better if you select just serial+webusb?
  3. What version of windows do you have?
  4. If none of the above helps, we need to check your drivers, which is a bit more involved.

1: no change
2: same results
3: windows 10
4: that was my worst fear

Checking drivers isn’t that hard, I’m going to go boot up windows to make sure I can provide accurate instructions though…

sounds good, I appreciate the help

Ok, Windows 10 makes this a little weird to find, but here is what I recommend:

  1. From the start menu, go to settings. (click on the gear)
  2. Click on “bluetooth and other devices”
  3. Over on the right side, under “related settings”, click on “devices and printers”.
  4. Find the proffieboard, right-click and select “Properties”
  5. Click on the “Hardware” tab.

On my (working) system I see this list:

Name Type
CDC Data Universal Serial Bus Devices
F:\ Portable Devices
Tlera DOSFS USB Device Disk drives
USB Composite Device Universal Serial Bus controllers
USB Mass Storage Device Universal Serial Bus controllers
USB Serial Device (COM3) Ports (COM & LPT)
  • For WebUSB, really the only one that matters is the CDC Data device. So next we double-click on that.
  • Then click on the “driver” tab.
  • Click the “Driver Details” button.

It ought to say something ending in winusb.sys

Is this the same on your system?

I also tried it with your config file, which also seems to have worked.
Although I don’t have the same fonts, so there may be something there.

everything seems to be correct for the CDC driver

You’ve likely figured this out but I had the same issue. The following worked for me:
I disconnected (or eject then disconnect) cord, then go into setting>devices, locate then remove/unpair device (Proffie) . I then went back to WebUSB website, select USB button. It will say something like no no board was found. I then reconnected the cord/proffie. When you plug it in proffie board will appear. Select proffie board and WebUSB worked from there…

Not sure if it makes a difference but I had selected "serial’ and “webUSB” under tools menu, no mass storage.

I was using 2 different KR Sabers Proffie 2.2 one of which i had previous used WebUSB to edit with.

That screenshot is unreadable, which makes it useless.