The Bitch is Back - SD Card Not Found

I was hoping we’d seen the last of this gremlin, but I just completed an install and it’s back.

OS is 7.8, so includes all the changes the Prof made to SD card handling that we hoped would kick this problem into the long grass. I just did 40 boots and got the SD card error on nine of them.

I realise this seemed to affect a particular batch of Proffies that were circulating about a year ago, and this board may very well be one of those boards as it was a complete install kit that a customer enquired about some time ago, and his name has only recently reached the top of my in-tray, hence I’ve only just built it.

The config is below just in case it helps, but there’s nothing unusual about it that I’m aware of.

Ultimately I guess there’s nothing to be done but live with it. Hopefully this will be the last affected board I come across. Fingers crossed. :crossed_fingers: :pray:

I still believe this is due to a hardware variance or issue specific to that run of KR boards that came out with the Thrawn Hunter’s first run. That is when it kicked off and my only board that experienced the issue. I tested over a dozen boards and this specific board from this specific run is the only one that ever exhibited.

Yeh I agree. I’m no expert, but it always felt to me like there was some tiny component that was manufactured to a marginal spec - no doubt off the back of lockdown and the great semi-conductor shortage that followed - so that all the boards at that time were close to the edge and a few just tipped over it. As I understand it, the Prof re-worked how the Proffie used the SD card off the back of it in OS 6 and 7 - I think partly due to this issue but partly because he just figured out a better way of doing things. It seemed to help in many cases, but I guess one or two from that era will still slip through the net occasionally. :confused:

I assume you’ve already tried a different SD card?

So, this issue was never fully explained though.
There is a thread around here that goes into all the gory details, but the summary is that I was sent a board that exhibited this problem. When I started testing on/off behavior, the SD card got corrupted, and this caused a lot of problems. So I set out to solve the corruption problem, and once I had done that, the “sd card not found” problem seemed to go away. At least I, and a few other people were not able to reproduce it anymore.

I still don’t quite understand the problem though, because even a corrupted sd card shouldn’t really be able to cause an “sd card not found” error, but that is still what happened somehow? Since I don’t actually know how it works, it’s entirely possible that my changes have not actually solved the problem, just hidden it better…

We did have one other report of something similar happening, and because of that I added a new define:


This define is only available on github master (not 7.8)
With this define, proffieos will say an error code when you get an “sd card not found” error, and that error code can help narrow down the cause of the problem. (maybe)

Anyways, please try this define and hopefully we can go from there.

I did indeed try a different SD card but no difference.

However I may have found something. In the course of trying your Verbose logging, I uploaded a config with Serial + Mass Storage (so I could easily keep deleting temp files between uploads) and found that I couldn’t recreate the problem in 15 consecutive boots.

So I went back to Serial + WebUSB (which is how I normally upload so customers can tweak if they want to) and the problem was back within four boots.

I then tried Verbose Logging with the Github OS uploaded with Serial + WebUSB selected and found that the failed boots were back, and it gave a weird male voice warning to check the SD card on those duff boots. The Serial Monitor from that sequence of boots is below. The only clue I can see is an error 16 which hopefully will mean something to you.

Finally I went back and reloaded the original setup, but with Serial only (no WebUSB or Mass Storage) and got 15 consecutive clean boots before I stopped trying.

So it would appear - after the saga that this has been - that WebUSB may somehow be at the root of it, though I’m surprised we didn’t find any such link with it sooner.

Suffice to say, I think I’m going to ditch WebUSB when uploading configs in future - for the time being at least.

Hope this is all useful and we can finally kill this gremlin once and for all.

This seems to be the same as this thread:

It’s very strange that it would be related to webusb though.
When you are testing this, is the board attached to USB?

Yes I agree - that very much mirrors my own experience.

I tried both with and without it connected as I was trying to get serial monitor data. But whether battery powered or USB powered the results were the same. Going to Serial only when uploading has definitely improved it for me.

Worth noting maybe. I recently replaced the speaker amp thing on a v3. I put it on backwards at first and it gave the SD error. Fixed the part and the board was back to normal. None of the other symptoms as mentioned previous in the thread, literally just the SD issue when the speaker thing was on wrong.

1 Like

I normally upload serial+mass storage, including when I was having the Sd not found issues

1 Like

Wait, was this an init error, or a check error?

SD check error: 16

1 Like

Yep, as Brian said, Check Error.

Does it shed any light?

I finally got around to reading the code, and unfortunately there are still too many possibilities for what is going wrong.

Is this still happening?
If it does, I think I should get a full copy of your output directory and see if I can replicate it on my board.

Unfortunately the hilt I was experiencing this on has now been sent out to its new owner (minus WebUSB being active). I’ve not used WebUSB since, and I haven’t experienced the issue since, but I’ll start using it again on the next few installs to see if I can recreate the symptoms.