Smooth swing effects do not work

Hello everyone, maybe someone had before such a problem on a ProffieBoard 2.2. Smooth swing effects do not work, and gestures to turn on the saber also do not work. Only stab effects works. I use ProffieOS 6.7 and ProffieBoard 2.2. Previous builds works fine. May be I missed some file on SD card, some config? Or just demaged somehowe motion sensor (gyro) on board while I desoldered microUSD port? May someone could show me where motion sensor (gyro) is located? Thanks a lot for any suggestions and ideas in this case.
Video can be viewed here: https://www.facebook.com/reel/836112338166189

It looks like the sensor (gyro) should be working properly, because dynamic color change works when turning the saber. Video:

It feels like the reactions to movements are mixed up; when rotating, it doesn’t turn on/off but creates a shock effect. I tried disabling the on and off gestures, but it doesn’t help get smooth swings back. Video:

Try hooking up to Serial Monitor and see what it’s outputting.

In Arduino > Tools > Serial Monitor

You can copy the output and paste it here for us to have a look.

Also double check the font contains smoothsw.ini file on the SD.

1 Like

Hello and thanks for your fast reply!
When lightsaber is on:

Battery voltage: 4.17
EVENT: Power-Pressed#1 millis=129260
EVENT: Power-Pressed millis=129260
EVENT: Power-Released#1 millis=129380
EVENT: Power-Released millis=129381
EVENT: Power-Shortclick#1 millis=129381
EVENT: Power-Shortclick millis=129381
IgnBattery voltage: 4.17

When off:
Style RAM = 672
Style RAM = 92
Style RAM = 52
Style RAM = 24
Style RAM = 28
Scanning sound font: Scavengers_Destiny done
Activating polyphonic font.
Activating SmoothSwing V2
Accent Swings Enabled.
Polyphonic swings: 16
Monophonic swings: 0
Accent SlWelcome to ProffieOS v6.7. Type ‘help’ for more info.
Battery voltage: 0.12

I have 16 different soundfonts and every of it have smooth.ini files, checked.
I also uploaded my config file:

Ok, we need to see Serial Monitor output while the saber is on and moving, just be careful to support the USB connection so you don’t put too much stress on it. We want to see what is output when the saber is supposed to be playing sounds and moving.

1 Like

Oh, I see. I will make it and will reply you as fast as it possible. Thanks!

This is what I got when turned on lightsaber and trying to swing it and spin:

You’re getting a LOT of clashes in quick succession, are you hearing or seeing clash effects? That is not normal.

Yes, I see the effects of clashing simultaneous collisions, all the LEDs on the chassis flash as if from impacts, and sometimes the display freezes, probably due to the large number of events.

Yeah, there’s something going on and it’s most likely the cause of everything else. Start by lowering your volume to see if that helps. Go down to like 300 ~ 500 on volume and see if it fixes the clashing and the swinging becomes audible (this would mean your speaker/volume are the cause). If lowering volume doesn’t fix then there’s an issue with the board or wiring causing which may be harder to narrow down.
If you post your config with pastebin we can offer some other defines you can try if it is the volume causing the clashing.

Might want to check that the gyro and accelerometer are working as expected.
You can do that with the monitor gyro and monitor clash commands in the serial monitor.
(If you have DISABLE_DIAGNOSTIC_COMMANDS in your config file, you’ll need to remove that and re-upload for these commands to be available.)

Note that if you see no values, you might just need to turn the saber on, as the motion chip is generally sleeping when not needed.

This page shows where the motion chip is:

(U2, “motion chip”)

1 Like

Tryed lowering volume level, didn’t help. The reactions to movements are just somehow mixed up, perhaps this board was defective, I have a similar Chassis assembly, completely with the same wiring and it works perfectly, I don’t understand what could be wrong with this one…
This is my config file:

Then probably best to try what profezzorn suggests above, it would seem there’s something with the board if the volume wasn’t the culprit.

1 Like

Tested monitor gyro and monitor clash commands:

Found motion chip on schemes. Think I can’t demaged it in any way, even when I desoldered the microUSB port, I didn’t heat up this area too much. :frowning:

@profezzorn I think this was meant for you.

The gyro and accel values looks reasonable I think, which makes it likely that the gyro and accelerometers are working as intended.

I should say that these values area reasonable if you were holding the saber mostly still. If you were swinging it around, then they are not reasonable…

1 Like

Yes, these are the data in a calm position of the saber, only at the end I tried to tilt it a little. Well, this is a mystery problem to everyone, I’ll try to install other firmware versions, I’ve already tried 5.7, but without results, I’ll try even earlier versions.