Saber Completely Freezing Or Hum Will Cease

Been having this issue periodically where my saber will stop playing the hum track or will just straight-up freeze. It usually happens when using features tied to the aux button (in these instances, doing blaster deflect or tip drag). It doesn’t happen constantly but has happened about 3 times each. I feel it has something to do with how my aux button can be unintentionally pressed very fast and is causing the board to freeze up from too much input, but I’m unsure. My board is also using about 90 percent of the flash memory. Any ideas?

Sounds like your SD card is subpar or corrupt. You need 1200kbps read speed and 12 simultaneous audio streams.

Remove DISABLE_DIAGNOSTIC_COMMANDS define from config


Hook up to Arduino > Tools > Serial Monitor

Type ‘sdtest’

Wait for results.

If its less than above requirements you need a better performing SD card.


Yup, it is subpar. Read as 947kbps and 10.7 streams. What is a recommended sd card to purchase? Also, I didn’t have that diagnostic on my saber prior. Should I have?

You’ll want to ask in some of the saber groups, ever since the pandemic and subsequent shortages there’s a lot of poor performing cards on the market. I haven’t purchased any for a while so I can’t really recommend. Just note, you want to run ‘sdtest’ even if the packages says it’s fast, that doesn’t always translate (or it’s made up).

Usually users have DISABLE_DIAGNOSTIC_COMMANDS in their config to save additional memory. You don’t typically need those commands, so disabling allows you to free up storage for styles and features you do use.


Awesome, great to know. I found an old one from some time ago that has been sitting around, pre-pandemic. Gonna try to give it a shot and if that fails I’ll dig around. I was also trying to find ways to save memory so that’s an extremely helpful tip, thank you!


This was extremely helpful, thank you! The other SD card was a little bit worse tbh so I ordered some Kingston industrial 8 gb cards as the forums have said very good things about them

If anyone in the future has this issue, I would direct them to Kingston Tech Industrial micro SD cards. People in the community have said great things and I got a two-pack of 8 GB cards on Amazon for about 20 bucks. After testing the first, it’s picking up at 1239 kb/s and 14 streams. Massive increase compared to my other cards.

The issue has begun again. Usually, it does it when testing clashes with no blade in the hilt. It rarely ever completely freezes, the hum track will cease to play. swings and clashes will still work. If I switch fonts it works as normal. I rechecked my streams and kb/s and they are both over the standard 1200 kb/s and 12 streams. It also strangely happens the most with Kyberphonic’s Werewolf and Sun Skoll fonts, which are noticeably more bassy than the rest of my fonts. Any other ideas?

What does Serial Monitor say?

Unfortunately, I can’t plug it in while it’s in-hilt so I’m not sure

re: If I switch fonts it works as normal. I rechecked my streams and kb/s and they are both over the standard 1200 kb/s and 12 streams. It also strangely happens the most with Kyberphonic’s Werewolf and Sun Skoll fonts, which are noticeably more bassy than the rest of my fonts. Any other ideas?

*It could be the speaker is freezing up but for testing to see if it’s that or not change up the font as switching to a different font, preferably one that is from a good backup and not copied/pasted too much may solve this. Just edit the code for that specific preset to a different font set. Now re-test.

This is unfortunately difficult to analyze and debug without serial monitor access.

What version of proffieOS do you have? There have been bugs like this in the past…

That was my thinking and why I edited my reply just now. You and I went through tracking this back in OS5. It could be a bad speaker but it could also be the font or other.

Definitely share which OS you’re on along with a copy of the config.

Tried #define KILL_OLD_PLAYERS yet?

Oddly enough, Ive experienced this as well with super bassy loud fonts. There might even be an old thread about it here somewhere. I always assumed it was part of the boards sound amplifier having some sort of ‘safety overload’ where if the incoming sound signal reaches over 0dbfs by XX amount, the amplifier shuts itself off before doing any damage to the board and just cuts the sound out.

This happened to me on a few select fonts, and I isolated which ones specifically did it…and which sound files it always occurred (accent swings in my own case) the sound to cut out abruptly, and then I did a hi-pass filter on the sound files as well as lowered the files gain/volume just a hair…and the issue went away.

1 Like

^I remember you telling me that at the time.

If this happened, it would affect all sounds, not just the hum.


Unless I did it wrong, it should be 7.12. Just updated it a few days ago. What is the best way to share my config? I’m still relatively new to proffie and the forums so pardon my dust. I really appreciate everyone’s help! I just tried the define and put it through the ringer with clashes and it didn’t have any issues, but I will test it more. Knowing my luck it’ll happen again

#ifdef CONFIG_TOP#include "proffieboard_v2_config.h"#define NUM_BLADES 3#d - Nevermind, here you go. Tbh this is just a modified config of the one that came with my saber so there could be some very redundant stuff on here. I did add some defines myself

I don’t see anything off about the config. That said I’m the type who always will ask “Do ya need it that loud? Maybe get a Smuggler’s Outpost Dark/Bass speaker instead.” Keep trying things out w the added define and if it reappears then first see if the speaker is locking up in movement. It may sound weird but I just diagnosed a failed speaker that would play most of the sounds but then randomly stop. The big part is the volume was never above 1750 but speakers can and do fail. To confirm it I gently held finger pressure on the cone and it would temporarily re-align the voice-coil and sound would play again. It was weird because at first it was only a certain sound, then as it progressed everything would stop. You may just have a speaker failing.