Repair thread: symptoms and solves

I have a ton of boards on the bench all looking to be evaluated and repaired.
Hoping to have this thread be a place for answers to issues and reference for the future.

1 Like

Board #1 - Blue Tritium from Electronics 123

Symptom(s):

  • No power or data when USB only. Dead.
  • Add battery power, all seems fine. Data communication, lights and sound all good.

Inspection:

  • no shorts anywhere from BATT+ or BATT-/GND
  • USB only - no 3.3v
  • Battery power - 3.3V good. 5V pad good, however ALSO 5V when no sound playing.
  • Suddenly 3.3v works after probing (slightly pushing on to make contact with pad) at D62. Then it went away again.

Fix:
Tried to reflow D62 and it fell apart. (seemed like it was brittle/no good.
Replaced D62, all is well.

3 Likes

Board #2 - Proffieboard v2.2 Black, no branding.

Symptom(s):

  • Everything checks out except no hum or smoothswing sounds.
  • No clashes.

Inspection:

  • Serial monitor shows single same swing pair playing at volume zero.
  • Serial monitor does not register and clashes when taping the rig.
  • Swinging around makes no smoothswing sound, no twist recognized.

Fix:
Replace U2 motion chip.
All working now.

3 Likes

Board #3 - Proffieboard v2.2 Black, CC Sabers

Symptom(s):

  • Exploded Q7

Inspection:

  • Attempt to remove really dead chip.
  • Chip crumbling when removing, and bits won’t let go of board.

Fix: NONE :frowning:
Whatever blew up Q7 at BATT+ was enough to weld it to the trace.
Removing stubborn bits, no matter how hot, wouldn’t release and traces ended up peeling up from the board.
She’s dead Jim.


2 Likes

Board #4 - Black Tritium from Electronics 123

Symptom(s):

*No USB data communication. Power OK

Inspection:

Fix: Replaced RN4. All working well now.

2 Likes

Board #5 - Proffieboard v2.2 Orange, KR Sabers

Symptom(s):

  • Loud squeal. No USB data connection.

Inspection:

  • One whole side of CPU is a big ol’ bridge.

  • RN4 has been chopped in half, and the missing side took the pads with it.

  • Not hopeful on this one. Assuming CPU damaged from the many shorts.

Fix:
Started with clean up of CPU mega-bridge. Fluxed the whole thing and reflowed with hot air. Actually looks promising now!
After:

  • Now to RN4. Removed remaining 1/2, pads still good there.
    The plan is to scrape away some trace mask and some on the opposing side VIA.
    Overblob solder, and use the force…

Well, that came out looking pretty good as well.


However, still no data WHILE ON TESTBED POGO PINS.
But, it shows up on Port when just board to USB. Hmmm. desolder/clean board pads.
Upload test config.
All looks good in Serial monitor. Back to testbed…

It’s alive! All working well.
Remember, The Force will be with you…always!

4 Likes

This topic is oddly therapeutic. Keep it going. :smiley:

1 Like

Board #6 - Proffieboard v2.2 White, KR Sabers

Symptom(s):

  • No response on USB. Boots with Battery.

Inspection:

  • 3.3V pad has 5V with both USB and battery power. Suspect U60 bad, allowing backflow of 5V?
  • Don’t want to leave powered too long for fear of cooking CPU, just long enough to meter then remove power source.

Fix:

  • Replace U60 - USB data working now, 3.3V stable. But data1 is dead.

Additional inspection:

  • R5 meters at proper 470, but I have no continuity between the resistor pad and the data1 pad. But probes from metering the resistor and the data1 pad…makes the LEDs work. (connectivity through the meter, bypassing resistor?)
  • Replacing R5 for fun. - no change
  • Microscopic break found in trace at the pad edge.

should be like this
Screen Shot 2022-05-24 at 3.43.47 AM

*Tried just solder bridge to reconnect. Too much “magnetic” attraction to big pad, won’t stay over gap.

All working well.

3 Likes

I came here to say that. I feel like an entire subreddit could exist for this.

1 Like

And there’s probably a market for getting boards repaired, considering the cost of new ones currently.

2 Likes

At the moment, it seems I AM the market.

3 Likes

6hd1c7

2 Likes

Yes you are. I love this thread. I have a few in Proffie Heavennnnn that might be able to be brought back to life via this thread and your posts.

3 Likes

Great thread Brian. Really interesting, but raises so many questions…

Such as, in your view are most of these issues caused by installer errors, or are the faults caused at the manufacturing stage?

Without wishing to finger point, are boards from some vendors more prone to issues than those of other vendors?

Is there an underlying QC issue in what might loosely be called the Proffieboard industry?

What steps would you recommend people take, especially people new to saber-building, to prevent these issues arising or catching them before they do more damage?

I should add I’ve been lucky and so far (touching lots of wood here!) I’ve only had one board with an issue that I couldn’t save, and that was a very early 1.5 install I did. But you never stop learning in this game so I’m always interested in being better informed of potential perils in the future. :slight_smile:

1 Like

@NoSloppy I have an old 1.5 that I accidentally tore some SMDs off with overzealous soldering (I was still a newb). I’m happy to send it to you if you want it. It’s just sat there anyway…

  1. My guess is installation or use assuming testing was done at manufacturing time.
  2. Vendors are being listed if identifiable and the sample set may or may not represent the bigger picture. Reports in other groups and forums in the community may be more telling.
  3. I don’t think there’s an underlying QC issue as long as testing is done.
  4. Always check the board with a meter and USB only before anything else, then solder carefully, precisely, and properly.
2 Likes

Sure, why not.

PM your deets and I’ll send it when I have some time. I’ll let you know when it sets off.

Board #7 - Proffieboard v2.2 Black, no branding.

Symptom(s):

  • No sound.

Inspection:

  • Desolder and clean all pads
  • No 5V on 5V pad when sound should be playing.
  • 3.3V ok so assume U60 and Q7 probably ok.
  • Suspect U3, the 5V booster. However, there isn’t even crackly sound (like when on USB power only and 5V booster is not on) so possibly bad U1 amp too.
  • Serial monitor all looks normal.

Fix:
Replace U3 booster chip.

  • Hmm still no 5V nor sound. Not impossible donor board U3 was also bad, but…Q7 seems good. There’s battery voltage on pin 4 (at via next to U2)
  • Before proceeding with 2nd swap, need to phone a friend

@profezzorn, what do you think?
No 5V still after U3 swap. The fact there’s no sound at all though, aside from possibly also bad U1 amp, could CPU be involved making this a wild goose chase on the booster?

continued

  • Swapped L1 coil. No change
  • Swapped U1 amp, no change. Still no sound, no 5V.
  • Replaced U1 amp with Brand New Part…Still nothing :frowning:
  • Not sure what else

It’s hard to say what’s wrong.
If the 5v booster is working, you should be able to activate it manually by putting 3.3v on BOOST_EN.
If it’s not working, it could be because L1 is busted.
If you short 5v and BATT+, do you get sound?