ProffieBoard works only after upload

Hi there,

I’m new to this community, so just quickly introduce myself: Christian, 48, software developer, passion for 3D print, electronics and software.

I got the ProffieBoard up and running without problems. But as soon I disconnect from USB and power it stand alone, it doesn’t work.
I already found this problem but the diode seems working fine (bridged it and checked with a multimeter)
ProffieBoard Won’t Power On Without USB - Proffieboards - The Crucible (

Here’s the exact behavior on different settings:

  1. Power only: Board doesn’t work
  2. Power + USB: Board doesn’t work
  3. Power + USB + Upload the code: Board works without problems
  4. Power + USB + Upload the code + disconnect from USB: Board works without problems

Would be great if someone has an idea.

Thanks a lot :slight_smile:

My guess is a stuck boot button.
Does the board show up as “STM32 BOOTLOADER” when you connect it to a computer?

Thanks for your reply.
Yes it’s showing up as STM Bootlader. The upload works as well (showing downloading and the percentages). As soon the upload is finished I hear a short sound and can then turn it on by pressing the button.

I haven‘t looked at the code but is there a possibility to directly turn the board on without the button press? Not sure if it gets stucked in deep sleep?

(I forgot to mention my config: ProffiBoard v2.2, 1xButton, 1xStrip, powered with a power supply)

You should disconnect power and measure if the boot button registers as a short. If it does, you would need to replace the button (unless you have warranty on the board.)

Sure, just put prop.On() at the end of setup().
Since there is no deep sleep, I don’t think it can get stuck in it though…

I measured the boot button already and it’s working fine.

I have also added prop.On(); at the end of the setup function but strangely it doesn’t start at all now.
Usually I hear the short blade sound directly the upload is sucessfully done and the board works.

I would do some debugging with the serial monitor but the port isn’t shown up in Arduino and so I can’t use the correct port. (I’m on Windows 11, maybe I could try an older laptop still running Windows 10 or a virutal machine with Linux)

I already wrote to the shop where I bought the board but there are little bit hestiant to send a replacement.

Just out of curiosity, what happens if you remove the SD card and try to use?

Did it ever work correctly? (booting into ProffieOS when power applied)
Did you check for a short on the 2 pads that the boot button is soldered to?

Behavior is the same but after uploading the code, I get another audio output. (I guess something will be player from the internal flash memory as the SD card is missing)

It doesn’t work if I apply power only. Also with USB connected it doesn’t work.
Only way to get it working is to connect USB (also without external power) and upload the code. Then it works completely for this moment. As soon I reset or remove the power I can’t bring it back.
I think the first guess from @profezzorn is correct and the board got stuck in boot mode all the time. At the moment I’m uploading the code, it seems to get out of the boot mode somehow. Restart will then put it in boot mode. I found a thread from someone else who had the exact same issue and he completely cleaned the board and it was working after this. But I don’t have the experience and the equipment to re-solder the board. I removed all externals part already and cleaned the pads to make sure there’s no unwanted connection but this didn’t help either :frowning:
I have order now a new board and get one extra for free at least.

As I’m on my wisdoms end, just tested an older notebook with Windows 10 but everything keeps the same. I can only see now a port in Arduino but connecting via serial monitor is still not working.

Bootloader is triggered by applying power while the boot button is depressed. That’s why it keeps doing it after power interruption but not after upload. Uploading never disconnects the power. So it has a chance to reboot into ProffieOS properly.
You didn’t answer my first question. Did it ever work properly?
And the second question was did you check for continuity on the two pads that the boot button straddles?

I know how the bootloader works and there was never the need to set the board into bootloader mode by pressing the button while applying power. I could program the board always.

  1. The board was never working properly. It behave as described from the beginning.
  2. Yes, I check the boot button with a multimeter and check for continuity. The button has continuity only while pressing the button. So working as expected.

That was kind of my point; that it’s always booting into bootloader when power is applied. You were able to program it and things worked until you removed power.

If the 2 pads that the boot button itself isn’t shorted regardless of the button (meaning the button is working in and of itself) have you tested RN1 on the bottom?
The 3.3v rail goes through the button when depressed and ends up at the CPU as well as here as BTN:

I have checked RN1 (100k it’s ok) BTN1 against 3.3v and it’s not going through.
I tried to check 3.3v on the boot0 pin on the ST32. (I hope I got the correct pin. Text on the chip is upside down then it’s the 5th pin from top on the right hand side). Couldn’t get any values here.

This picture shows fairly clearly where the BTN tracks go:

Did you measure in the right place?

I measured already on the correct pin, but thanks for hint.
On the boot0 pin I have by default 0v and if I press the boot button I have 3.3
So the board shouldn’t be in continuous boot mode.
Any other idea what I can check?

Thanks in advance

I suppose it could be the reset cap that is faulty.
Reset has a capacitor that is supposed to delay startup a bit to make sure the power is working properly. If this cap is broken/missing, then the CPU might start up in a state where 3.3v is not yet stable, which could maybe cause it to go into boot mode?

This is a bit of a stretch though. It could simply be that the CPU is not working properly and the whole board needs to be replaced.