ProffieBoard Won't Power On Without USB

I have a new Proffieboard 2.2 that I got in a Saberbay PixelCore. Day 1 it worked great. Day 2 I had to plug it into my computer to unfreeze it. Day 3 it happened a few more times. Today, I can’t even keep it going for an hour.

When it’s in this quazi-sleep state, the 3.3v line is at 3.3 volts, the battery is around 4 volts, and the 5v line is at about half a volt. Once I connect a USB power source to the Proffieboard, I get the boot up sound and everything works normally, even if I unplug it. But, not long after, it will shut off and will be inoperable until I plug it into USB again.

Also, all of the volatile memory is lost when this happens so the STM32 is either losing power or resetting. The reset button will force it into this state. The boot button has no effect. Trying to put it into bootloader mode doesn’t do anything either.

I feel like something has to be going on with the VBUS signal, like the STM32 is getting into a state where it hangs until a USB connection is detected, but that’s a little too over my head, even though I did try digging through the board specific files looking for clues.

Help? What do?

If a Proffieboard doesn’t boot on battery power, you might have a bad D61 diode.

If it does boot when connected to USB, power on and see if it stays running on battery power when you pull the USB. If it does, kill power and confirm it does not boot when using only battery power. If no boot, this might be your problem. It happens.

Another test if that’s the issue, is to jumper bypass the diode and see if the board boots from battery power, but that’s pretty tough to do.

Of course you could also use diode test mode on a multimeter.
If it is a bad D61, here’s the link to the part. You’ll need solder paste, a hot air station, kapton tape (optional) ,and a very steady hand. USB Microscope cam helps.…/nexpe…/PMEG2005ELD,315/2704871

The probes on my multimeter are too large to test the diode directly, but what I can say is that it boots on USB power and remains running when I disconnect, for a time. That time has gotten shorter over the past few days. Also, if I hit the on-board reset button, that kills the power too. The 3.3 volt regulator is unaffected, which is downstream of D61 so I’ve all but ruled it out (googling indicated I should check that diode). I may be able to find some smaller probes to test it and be sure though.

I do happen to have solder paste and a rework station and I have some SMD experience, albeit on larger package parts. Enough that I was going to attempt to assemble a fresh proffieboard once I get a few more dollars to play with.

Okay I was able to test the board today and it is the d61 diode. The moment I bypass it, it powers right up. And I did try reflowing the connection first so I’m confident I can replace that component without issue. Thank you so much for your help.

Nice work. Parts are cheap to just replace it.

A quick and dirty search tells me that diodes failing open circuit usually comes from overcurrent, so I think I’m actually going to grab a 1 amp diode in the same package and same speed. We’ll see if that lasts longer.


I have a similar problem. Board won’t turn on without usb. When plugged in I have to turn on the kill switch to start it. Then turn off the kill switch. If I don’t turn off, then LEDs wont work properly.

The blade dies instantly when I pull the usb.

Not sure what to do/start…

Additional info; it’s a KR Sabers Krossguard. I had just redone all the cables. Then I noticed the chassis was very unstable so I dissembled it somewhat to get to the screws behind the “engine”. After that was done, I tested the saber while laying on the table, not fully assembled. It worked, but something happened while I did this power on, like it shorted or something.

But it does work with usb and I can see stuff happen in the serial monitor.

The answer is already in this thread: D61 is bad.