Proffieboard boot up is looping on desktop

Hello all, I an trying to upload a sketch to my saber using OS6 for the first time. When I plug in the cable to the desktop the chime keeps on looping over and over. The boot up sound plays on the saber and when the boot/reset buttons are pushed the boot sound plays on the saber again. In Arduino the port is greyed out. I went to “Devices and Printers in “Control Panel”. This is the information I found.
“Proffieboard Properties”
“USB Composite Device”
Device status This device cannot start (code10)

I can program the saber no problem on OS5.9
Any help appreciated

So, I think what happens here is that some part of ProffieOS is crashing early on during connection, causing it to re-connect over and over. It’s been reported before, but we haven’t had any good idea of what’s actually happening.

First thing to try is to program the board without “mass storage” and see if that helps. (Also, the SD card can get corrupted if proffieOS crashes while you’re connected to a computer, so you don’t really want mass storage on while sorting out this problem.)
Second thing is to try a different SD card, with NO FILES on it.
Also, if you post your config file, I can try it and see if I get the same error.

Profezzorn, I have changed USB type on Proffie OS/ Arduino to just serial. I have also tried another formatted sd card. The computer just keeps chiming over and over like it is trying to connect but can’t. I can post my config for you but it checks out when I verify it in Arduino.

Please post your config file.
Also, have you tried a different USB cable?

Ok, I will try to get it up here. I have not tried another cable, this one works fine with OS5.9. I have another and will try it out.

How would I post my config? That’s embarassing!

I have just tried another cable and get a different notice from the computer. USB Device not found. Earlier in the day I could upload a config using OS5.9, now I get the same warnings as in OS6.

If it’s not too large, just put three double ticks on a single line, cut-n-paste the config and end with three backticks on a single line.

it will look something like this

If it is too large for that to work, use pastebin and post the link here.

Should I delete OS6 and start over?

No, why would that help anything?

I don’t see anything obviously wrong with your config file. I’m going to try it myself and see if it works for me.

Thankyou for getting back to me. Profezzorn, I cannot connect to Arduino, port is greyed out. Forgive me but what does the config have to do with the connection problem?

Depends, sometimes nothing, sometimes it matters.

When the board is running in ProffieOS mode, ProffieOS is responsible for keeping the USB connection running. If ProffieOS crashes, so does the USB connection. Most of the time, config file problems don’t make ProffieOS crash though. An interrupted programming can also cause these sort of issues.

Normally, the fix for these sort of problems is to use BOOT+RESET to put the board in bootloader mode, and at that point the config file is 100% irrelevant.
Then you can program the board, and if the new programming is done with a config file that works and doesn’t get interrupted, then the connection ought to work better. (Assuming it’s not just a cable problem of course!)

more information:

Yes, I have tried the boot/reset and the computer just keeps on chiming and trying to connect. Every time I “boot reset” the font plays. Unless I have the new fonts on the sd and then it says font not found.

The cable I am using works ok on OS5.9. Shows the port and I can download a config no problem. Only when I use OS6 the computer will not connect.

Then you’re not doing it right.
No sound will play when the proffieboard boots up in bootloader mode.
You need to hold the boot button, press and release reset, then release the boot button.

I tried your config file, and it seems to compile updload and run just fine for me.
I haven’t tried hooking it up to a windows computer, but it seems unlikely that that would make a difference.

When you had it working before it was running 5.9, right? Did you install that, or did someone else?

I installed that. I have boot/ reset and in “USB Composite Device Properties” under “Device Status” it says “This device cannot start. (Code 10)
The requested operation was unsuccessful.”

Not sure what that means.
Either the board crashed right reset, or there is some sort of driver issue.
I’m starting to wonder if you have a hardware issue, like maybe the CPU isn’t getting power, or there is a short somewhere? Is the CPU getting hot?