Proffie 3 fail to mount SD card

Hi there,

Got a Proffie 3 when they launched, just started messing around with it. Wanted to do some SD card tests, but I can’t get the SD card to mount. I have tried most of the troubleshooting steps I can think of and that I have available to me, but I’m starting to wonder if I got a bad board.

I am not entirely sure of the best format for this, so here’s the general sequence of events:

  • Plug in Proffie 3
  • Using Arduino 1.8.x (it’s 1.8.19 on my Mac, my Windows PC is shut down for the night but I can check on the version tomorrow) and plugin 3.6, I flash proffieOS 7.7 to the board. Flashes without a problem.
  • Open serial monitor to check the SD card and get several SD card mounting errors. On Windows, I get constant Windows notifications of the SD card mounting – once every second or so, maybe a little faster. This continues until I unplug or reboot the board. On Mac, it will run the SD test but it will show zeroes with the SD mounting errors interspersed.

Things I have tried:

  • Two different SD cards, both reformatted to FAT32. (I will note that neither was the card that came with the 3.3 – one was a card that came with a 2.2 that I have been using for a few years with no problems and the other is a card I use in my camera.)
  • Tried both SD cards in an installed proffie 2.2 and a loose proffie 2.2, did not get any mounting errors. sdtest command ran successfully on both boards and both SD cards.
  • Two different micro USB cables, same results.
  • Multiple USB ports across both Windows and Mac machines, same results.
  • Tried the solution in this thread: with no change in behavior.
  • Realizing right before typing this and right before I go to bed that it could potentially be a bug in 7.7, I flashed 6.7 (the last version I was using) on Mac and was getting a motion initialization error instead of the SD mounting error. I can’t remember exactly what the error was now, but I can do some more testing on previous OS versions tomorrow.
  • All of the tests above except for the very last one about previous OS versions were done on both Windows and Mac.

Open to all suggestions on what else I should try. Or if you also think I got a bad board, I can contact about a replacement. Happy to provide any other information, screenshots, and do any tests you suggest once I get home from work tomorrow.

Update: In helping someone else troubleshoot a thing, I realized I forgot to select Proffieboard v3 in the Tools → Boards section like a dumb-dumb. Problem solved. Feel free to delete if you don’t want this taking up space, but also feel free to leave it if you feel like it will help other people not be dumb like me. :joy: :sweat_smile:

1 Like

I’m glad you figured it out.
It may help other people, so I will leave it.

1 Like