Possible ProffieOS 7.7 + v3 bug? Cannot run anything on Serial Monitor nor access WebUSB

Renamed and moved the directory, re-installed 3.6.0, issue still there. :frowning:

For now, I’m just gonna switch to 6.9 to at least test out sd card speeds.

Well, I have one more thing for you to do if you don’t mind:

If you could compile 7.7 again, then provide a zip file with the contents of the arduino build directory. (Should have a ProffieOS.ino.dfu, and some other files in it.) With that, I should be able to run a debugger properly, which might let me find out what’s going on.

To find the arduino build directory, just look at the compilation output, and you’ll see a line like this:

C:\Users\R2\AppData\Local\Arduino15\packages\proffieboard\hardware\stm32l4\3.6.0/tools/windows/stm32l4-upload.bat 0x1209 0x6668 C:\Users\R2\AppData\Local\Temp\arduino_build_449252/ProffieOS.ino.dfu 

In this case, the build directory is:

Sorry about all the weird requests, but this is turning out to be a pretty weird problem.

1 Like

Not a problem! I’m grateful for all the help you’ve been! Glad we’re working to figure something out since it seems I’m not alone!

So oddly, for testing things out, I tried 7.7 on a v2.2 board. Serial monitor and webUSB worked fine. Same config, same modifications to colors, really odd.

Got a new v3 (the one USPS misplaced). Same conditions, serial monitor and webUSB not working. LED is solid.

Ok, so I may have found something:

This could either be tested with the latest version from github, or by applying the above one-line fix to the 7.7 code.

If this works, we’ll have a 7.8 release shortly.

1 Like

There it is! Works like a charm! Serial monitor and WebUSB working perfectly, LED on board now pulsing instead of solid!

Well, mostly workING. Only slight new thing I found was it keeps registering clashes and stabs in the serial monitor. Board is not moving at all on a flat solid surface, no vibrations elsewhere.

EVENT: Clash millis=11548
EVENT: Stab millis=11860
EVENT: Clash millis=12003
EVENT: Clash millis=12259
EVENT: Clash millis=12890
EVENT: Clash millis=13002
EVENT: Clash millis=13275
EVENT: Clash millis=13478
EVENT: Clash millis=13994
EVENT: Clash mEVENT: Clash millis=15226
EVENT: Clash millis=15389
EVENT: Clash millis=16510
EVENT: Clash millis=16660
EVENT: Clash millis=17505
EVENT: Clash millis=17748
EVENT: Stab millis=17997
EVENT: Clash millis=18324
EVENT: Clash millis=18558
EVENT: Stab millis=18728
EVENT: Clash millis=18992
EVENT: Stab millis=19179
EVENT: Clash millis=19527
EVENT: Clash millis=19855
Battery voltage: 3.33
EVENT: Clash millis=20026
EVENT: Clash millis=20430
EVENT: Clash millis=20701
EVENT: Clash millis=21196
EVENT: Clash millis=21400
EVENT: Clash millis=21781

I’ve seen some of that, but I don’t know what causes it yet.
At the very least, it’s a new and different problem, so I’m going to make a 7.8 release. :slight_smile:

1 Like

Did you get these clashes on 7.7 + one-line-bugfix, or did you get them on github master?

Just when you asked, I tried both one line and github master. Both have it.