Possible ProffieOS 7.7 + v3 bug? Cannot run anything on Serial Monitor nor access WebUSB

Well, I guess the first question is if you can reproduce the problem on your setup.
(Using the same OS, config file and settings as described above.)
If you can, then the first question is: Does it happen on all boards?
If it happens on all boards, then the second question is: When does it not happen? (Which changes makes the problem go away.)

1 Like

I’ve noticed he has ENABLE_SERIAL defined. This should pose no issue?
@profezzorn Incidentally, I’m trying to adapt another config, and I’m wondering if for doing Blade ID I just define #define BLADE_ID_CLASS SnapshotBladeID<bladePin>, or do I have to do something like #define BLADE_ID_CLASS BridgedPullupBladeID<bladePin,bladeIdentifyPin>. Because I see that the pins are internally bridged, and in proffieboard_v3_config.h I saw that both Pin 0 and Pin 1 are thus defined.

OK, I took @Bruinrogue config verbatim. I set the Board to Proffieboard V3, “Serial+Mass Storage” and “DOSFS: SDIO (Default Speed)”. This board appeared as COM4 in my computer.
With no SDCard had no issue accessing the serial monitor. When I inserted the SDCard and connected again, it took some 5 to 8 seconds to be able to connect to the board. Before that it was having problems finding the serial port.

Edit: got the same result with “Serial+WebUSB”. I have Arduino 1.8.19, btw. And all this is with ProffieOS 7.7, of course.

Tried it on five boards, all worked pretty fine and had no problem with serial monitor. I don’t know how else to test for this problem.

That’s very helpful, and if you can’t reproduce the problem there isn’t much more you can do.
I do wonder if maybe the delay you saw could be what’s causing the problem. Maybe something times out…

I don’t think ENABLE_SERIAL should cause a problem.
You shouldn’t need to define BLADE_ID_CLASS, it will will automatically use the right class.
(If you have more questions about BLADE_ID, start a new thread.)

I wonder if @NoSloppy has had further issues as well. Another friend of mine not on here is also having the issue with his Tritium v3.

Interestingly, the web programmer was unable to Boot+Reset so I had to do it manually on the board. Not sure if that will be relevant down the line.

Okey, so when I put your firmware.bin on my board, serial monitor doesn’t work, and the status led doesn’t pulse anymore.

So that begs two questions:

  1. Why?
  2. What is the difference between your firmware and mine?

Debugging might be difficult without the elf file, but I’m going to try it…

1 Like

Interesting. Haven’t seen any changes myself re-downloading both from the github and your site.

Well, it is indeed difficult to debug.
I’ve figured out that it seems to be stuck in WS2811PinBase::EndFrame(), which really shouldn’t be happening.

It’s something I may have seen before though. Last time this happened, it was because of misconfigured DMA, wonder if it’s the same this time?

To help figure out this one, could you go into Arduino → Preferences and make sure that the “show verbose output during compile” checkbox is on, then press verify and then paste in the full output here?

Here ya go!

Is this with 7.7 and the darksaber config file?
Because yours turned out much much bigger than when I did it…

Ah, yeah, sorry, I added a bunch of presets to test out after the initial upload. But it is with 7.7 and the rest of the config file is the same (just had 1 preset vs 30+ that I just added).

Edit: New pastebin output

I still get a slightly different size binary, and I’m not sure why.
Would you mind zipping up your 7.7 directory and send it to me?

PM with the directory sent!

So I see you made some changes to 7.7, one of which looks suspicious to me.
(Adding colors to edit mode without updating LAST_ARG)
If you fix that, does it work better?

Although it seems that LAST_ARG isn’t used anywhere, so maybe that’s not it…

Still, could you try a 7.7 without your modifications to see if you still see the same problem or not?

Yeah, tried a non modified one and still came out with the same issues.

Just for eliminating a possible reason (and remembering the last time I had an issue, it was because the zipped file was different between the site and the github), I did an upload from a full, fresh unaltered OS from the github and still got the same issue.

So, there used to be an issue in the arduino-proffieboard plugin (pre 3.6.0) which would cause a problem very much like this. Now, as far as I can tell, you have version 3.6.0 of the arduino-proffieboard plugin installed, but at this point I’m really really struggling to come up with a reason for all this… so…

Could you try deleting or renaming your arduino15 directory, then re-install the arduino-proffieboard plugin and see if the issue is still there?