Odd Sound Behaviours With Bluetooth Module BT-909

Hello there!
In my build I use a BT909 module on a Shtok PCB. I wired it according to Page 18-19 of the Proffie Manual with a simple switch AND a 47uF 6.3V capacitor between 3.3V and GND.
My reasoning for this is, that I will not always need the BT and therefore want to be able to manually turn it off completely, but when I do, I want it to also IDLE OFF.
(If it helps I also have a 33kOhm pullup resistor on the otherside of the 3.3V to D1 for more precision in the blade ID department)

In general it works, but I get two odd sound issues that I want to take care of, if possible.

Behaviour 1:

  • BT-switch is ON and Power is OFF (battery is out)
  • When I plug-in the battery the first time (or plug in the USB cable) the boot sound is missing
  • I hear the speaker doing something but immediately stops
  • Now I can either unplug and replug the battery and the boot sound plays, or I can ignite the blade and the sounds are back

Could the bluetooth somehow be “sucking power” from the SD when turning on?

Behaviour 2:

  • BT-switch is OFF
  • I plug-in the battery (boot sound plays perfectly normal)
  • I switch on the BT-switch
  • When igniting the blade no sound plays, when I try switching fonts I get one of two different error messages: “Font directory not found” or - which I find even stranger - “Font directly too long” (it switches fonts but without sounds)
  • To get it back to working I could either un- and re-plug the battery, or connect via forcesync App and hit the “refresh” button in the middle of saber and mobile phone graphics.

Might this be “normal” behaviour for instance if it wasn’t properly initialized? But it would still be strange, that it messes with the font directory in that way.

Here is my current config:


Behavior 1 sounds like something to do with the capacitor maybe since the second attempt works, meaning it already has a stored charge and can supply the BT without drawing too much from the 3.3 pad?

Could be, but not sure how I could test this.

remove the cap…

Okay, I’ll try that later, but I would like to wait for another opinion or two, so in case I have to (de-)solder more than that, I’ll do it together.

I’m not sure exactly what’s going on here, but it sounds like at least some of these problems come from the SD card. I don’t know what kind of SD card you have, but maybe it is more sensitive to noise on the 3.3v power rail?

Other alternatives include: Cap not being big enough, cap being too big, 3.3v supply not strong enough, battery not charged, 909 module eating more power than normal.

Most of these issues could be worked around with an external 3.3v supply.

Another thing that might help with the power leeching when the module is off is to add resistors on the serial lines. Something around 1k ohm should work well.

Hey @profezzorn,
thanks for the reply.
I got a SanDisk Ultra, one of the recommended ones in the manual.
I ordered some Kingston as extras so maybe i can try these.

For CAP i got this: CL21A476MQYNNNG from Samsung. According to specs it should be what is required. But i got a few extra and maybe my soldering there was not on point, so I can try again. Maybe the tollerance of ±20% is too big of a problem. Is there a way to

Not sure how i can change a not strong 3.3v supply.

Issues happen with half drained and fully charged battery (Keeppower 18650 3120mAh 15A)

Not sure how to check if 909 module was eating more than normal. I would need to know normal. And where / how to measure mine. I ordered mine straight through @ShtokyD , so I would assume that it was properly tested.

How would i get an external 3.3v supply in? another battery? I fear I would not have room for that.

Not sure about the last part. I am really new to the hobby and soldering electronics so when you say serial lines, which lines should get resistors? But not sureif this would help because when module is off, everything is fine. Only when turned on, it gets messy in these specific situations.

I’ll try to re-do the capacitor as a first step.

I was just listing a bunch of things that could be happening. Some of those are basically impossible to fix.

An external 3.3v supply means putting in a regulator, I tried looking on Adafruit if there was a suitable one there, but I could not find one.

The easy things to start with is things like: Try two capacitors and/or try a different SD card. Ultimately, the biggest problem here is that the BT909 module draws too much power on startup, and more capacitors might help with that.

Okay, gotcha, I was trying to answer as many questions/suggestions as full as possible, so you might get a fuller picture.
Unfortunately I got the 0805 form factor which makes using multiple kind of hard.
Where could I place a second CAP? i can’t stack them, otherwise my lid won’t close. I don’t suppose i can just continue bridging from gnd to reset (sounds kind of dumb to get a current there without wanting it)

Edit: your idea with SD card related issue seems correct. I prepared myself for soldering and removed the SD card. For testing purposes I inserted the battery to see if it might also cause the problem with the sound. It does not. The error message for the not found font directory and SD card plays without issue.

To be honest, I’m not sure where to put them.
Can you put them side-by-side?
Can you put them side-by-side with the short edge down?
Can you put one on the bottom? (maybe dremel a space for it?)
Can you put it between the wires themselves?
Can you put it on the bluetooth module?
If none of these will work, maybe just buy a 100uF cap and try that?

1 Like

for science i just soldered one atop of the other.
It seems this worked for fixing at least behaviour 1. I will have to wait a bit and try again to be sure, because after short succession it would always work.

If this does the trick, i need to figure out a way to position them next to each other will still fitting in the available space. One of your suggested positions will probably work.

I’m always using 47uF 0805 capacitor between 3.3V and GND pads on Proffieboard v2.2 for BT909 modules without any issues. Which BT909 module you got? On a black pcb? If yes, then it already has a capacitor on the pcb.

Yes, your shtokCustomWorks black pcb one. So does this mean I do not necessarily need a cap at all?

Edit: Cap between 3.3V and GND i ment.

And I only ment because 0805 is bigger compared to 0603 it would be harder to place 2 next to each other like @profezzorn suggested.

@ShtokyD without the CAP between 3.3 and GND it is worse.
But maybe I misunderstood the CAP on the Bluetooth PCB

I created a monster.
Side by side seems to work. Will investigate both behaviours now.

Edit: both behaviours seems to be fixed by upping the size of the capacitor.

Thanks everyone :pray:

1 Like

Nice work!

1 Like

Yeah, you don’t need a capacitor on Proffieboard between 3.3V and GND with the black pcb BT909 modules.
Is it a Proffieboard v2.2? How did you wire it to the board? Negative wire to one of the LED mosfets outputs and Positive one to 3.3V pad or to SD power pad?

That 33kOhm pull-up resistor probably messes things up. Also you may try moving the manual switch to the GND line instead.

Hey @ShtokyD ,
It is a proffie v2.2.
It is wired to LED6 and to 3.3V not SD.
I tried removing my capacitor between 3.3V and GND which lead to the board freezing up.
It seems like the CAPs on the PCB are either not working for whatever reason or something (maybe the 33kOhm) interferes with them.
The only thing that worked was using 2 CAPs between 3.3V and GND.

Try removing also the 33kOhm pullup resistor, just to see if it causes the issue.
Also you can just solder a single 0805 100uF capacitor there instead of two 47uF…

Is there maybe an easier way to test this, than to remove all 3 components?
It was really hard to get the two Caps together in there. If I had a single bigger Cap I would gladly took it :wink:
Would it work to solder it to SD Power? With this I would in a sense remove those components.