No webusb found

I am trying to use the Easy ProffieOS Customization tool, but it says no webusb interface found. I have used arduino to program my proffie and followed all of the steps on the website. I made sure that the usb type is “Serial + Mass Storage + WebUSB” but it still doesn’t work.

Did you set the USB type before uploading? (or after?)

i set it before

I also set it multiple times

when using the Easy ProffieOS Customization tool, should I have the proffie board plugged in and the sd card in the board, the proffie board plugged in without the sd card, the proffie board plugged in and the sd card in the computer, or the proffie board unplugged and the sd card in the computer? (I have tried all of these, so I don’t think this will solve it, but just want to make sure I’m doing it the right way.)

The proffieboard connected with the SD card in.

(Why webUSB isn’t working for you is beyond me, just commenting on that one question)

Ok thank you.
Yeah, when it didn’t work I also tried pressing the reset button to see if it would help. (it did not)

Just making sure, sd card in the board or the computer?

Oh, my bad, was gonna clarify that and I guess I forgot.

SD Card in the proffieboard.

Thank you so much for the help. I’ll try a few more things.

1 Like

Update: When I press boot + reset, and then upload the code, instead of saying no Web USB found, it pulls up a connection menu that just says “No compatible devices found.” If I press the reset button on the Proffie board, it changes its name on device manager and control board from “STM 32 BOOTLOADER” to “USB Serial device” on device manager and “Proffieboard” on control panel. It is only after I press reset that it says “No WebUSB Found.” I also tried pressing reset and then uploading the code, but it also says “No WebUSB Found.”

I think the driver could be wrong, but I’m not sure.

This is the driver before I press reset:

This is the driver after I press reset:

The proffieboard should present as a multi-endpoint device, which has multiple drivers, not just a serial port. Depending on how you’re getting to this dialog, that may or may not be easy to see.

At 2:04 in the video below, you can see what it looks like when you only have serial enabled. If you have serial+mass storage+webusb, there should be more devices in that list.

Mine looks exactly like that, but I have programmed it with “serial+mass storage+webusb” in arduino ide. Please tell me how to get the other drivers onto the board.

Either you have not programmed it with “serial + mass storage + webusb”, or you did but then programmed it again with just “serial”. Either way, I would recommend reading this page:

I downgraded to arduino 1.8.3, but now it says:

"Board ProffieboardV2-L433CC (platform stm32l4, package proffieboard) is unknown

Error compiling for board Proffieboard V2."

should I switch back to the latest Arduino version?

Why? 1.8.3 is ancient.

Yes, please do.

This is why:
I returned to the newest arduino.

I will update that tonight.
It’s been a few years since that was good advice.