No response from the proffie board. Sound or light

So I had turned on my saber for the first time fully constructed and it got very hot to the point where it melted the glue holding my chassis together and when attempting to remove it from the hilt a few wires were torn apart. Ever since then I’ve had no response from the board even if I plug it into my computer. There is a hole on one of the modules at the top of the board don’t know if it relates in any way.

Sounds like you had a short and it melted your board.
Is the melted component a FET, or something else?

I’m gonna be honest don’t exactly know what an FET is but on the side with the USB port there’s a triangle formation of three black boxes and the top one is what has the melted portion. It was melted while still working which is what has me confused as well.

I’m not sure what “top” means in this situation.
Post a picture?
If the melted part was melted before, then other parts might be damaged as well.

That middle black box on top had that damage to it while the saber was still working. Then it all stopped afterwards.

That is indeed a FET.
A broken FET can usually be worked around by using one of the other LED* pads, assuming you can get the board to work at all of course.

I feel the need to ask you to please fix your solder joints though… stuffs gonna get shorted, and who knows what else, that may be what happened there…

Not trying to be rude, it takes practice and we all start somewhere, but you’re going to be better off practicing (preferrably on something else) and figuring out how to get good joints before you try soldering to the proffie.

How could I go about trying to get it to work. As of rn I’m getting no signs of life from kt

De-solder one cable at a time until the board is either working or no wires remain…

Every cable unsoldered and I still get no response on my pc. There’s some more damage on an FET on the back side of the board as well. Thinking it’s fried at this point

Is it Q7?

No it’s Q2 and where Q4 is but the other side

Those are just MOSFETS that are all the same for all 6 LED pads. A blown one wouldn’t typically be contributing to the board totally not working though. I’d suggest starting by checking for 3.3V DC on the 3.3V pad. Try with both USB power, then battery power.
It may point to either a bad D61or D62, or a bad U60 regulator etc…

Regarding the guy that said to cleanup uour solder joints, 100% do that. And like he said, not trying to be harsh bc we all started somewhere (and I’ve made just about every mistake in the book), I can tell by experience that you didnt use flux. Get yourself some of this (sorry i cant figure out hyperlinks on mobile- The best advice i can give a newbie is that flux is your friend, the right flux is your best friend. I spent years going through them before I found the right one, and it makes ALL the difference. Use it literally every time you tin ANYTHING and you will be amazed at the difference it makes. You’ve taken your first steps into a larger world.

You wont always get a sign of life from the computer. Sometimes the boards can just be goofy. Do the 2 button push and force your flash anyway. It will take it.

I’m not even trying to flash anything. When it was all soldered up it didn’t work. And looking closer at the board the metal contacts for each spot on the board are straight up gone on some leading me to believe they got melted off one way or another

I ordered a new board and will try to make my joints a lot cleaner on this go. I think the first board is not fixable

Which pads are gone? Fixable, no. Saveable, maybe.

Fixable is a possibility for sure. Just would require replacement components and the tools to replace them.

Not if he blew the pads though, right? Unless he wants to be crazy like you and scratch down through the solder mask to the trace lol

SMD components of course are fixable. One of the most valuable skills I have learned.