HELP PLZ nothing is happening after upload

i upload on board from arduino and once upload complet nothing is happening…I did the rest on the board then an other upload and once succesfull mad that booting sound… BUT here is the problem once i eject sd card an board … i put the battery in and nothing works…
IM 100% sur my config an sd settings are good sins i use the exacte same on other saber… please help i dont know what to do!!!

Can you program it again?

what do you meen to program again?

Does the computer recognize it?
If you hit program, does it upload?
What does the serial monitor say?

Yes my computer recognizes the board…it uploads and says complet… but then nothing happens… and i dont see nothing in the serial monitor…

Do you have the right board selected in Arduino → Tools → Board?
What does your config file look like?
Does the “beep” command work in the serial monitor?

How do i use the beep in comande? Never done it…and yea i use the good board…and my comfig is fine i use the same on other board and it works

Here’s how to use the serial monitor:

Posting the config file let’s help you better as I can see what features you use, which may matter.

The weird part here is that you don’t hear any sound from the board, right? (Is the speaker plugged in?)

Il test it tomorrow but yes the it was working yesterday… was changing for os6 for my friend and since then nothing works…

I just copied all my fonts and config from my own to his and now nothing…

Unfortunately this is not enough information to actually help you.
To figure out what went wrong, I have to know exactly what you did, how you did it, what works, what doesn’t work. The more information I have, the better answers I can give you.

Her is what i did and how so far…the board was running OS5 and i wanted to do the same as i did on mine…upgrade to OS6…using his laptop witch he never used before to program his board, we downloaded arduino and zadig. Then i made a copie of my fonts and config file on his laptop from from my own proffie sd card. i then open arduino to define the right config and update the proffie to OS6 in arduino… the board was not recognized by his laptop so i opened zadig to install the right driver… it didint apear in zadig…so with the board connected to le laptop i did a hold boot,clic reset and release on board. the stm 32 bootloader then apeared and installed it… i set the arduino as i always do for my own saber… tried to upload on board… worked but once it reached 100% we did not hear the usual boot sound…After a couple of tries i decided to do it on my computer back home witch i know works with my own board…tried it and still does the same thing… thats pretty much all i did so far… this morning i tried to connect my board in arduino and saw things in the serial monitor but the faulty one nothing apears…

It worked before the upload? What happens if you remove SD card, does it speak an error message?
Maybe post the config you uploaded just to see if there’s anything of interest?

Well the config i uploaded on it is the same as mine and i uploaded new fonts on mine after and it works…

#include “proffieboard_v2_config.h”
#define NUM_BLADES 1
#define NUM_BUTTONS 2
#define VOLUME 1700
const unsigned int maxLedsPerStrip = 144;
#define MOTION_TIMEOUT 60151000
#define IDLE_OFF_TIME 6051000
#define ENABLE_WS2811
#define ENABLE_SD
#define SAVE_STATE
#define FETT263_MAX_CLASH 16
#define FETT263_TWIST_OFF
#define FETT263_TWIST_ON
#define FETT263_TWIST_ON_NO_BM
#define FETT263_THRUST_ON
#define FETT263_SWING_ON
#define FETT263_SWING_ON_SPEED 350


#include “…/props/saber_fett263_buttons.h”

Try commenting out #define KEEP_SAVEFILES_WHEN_PROGRAMMING, he may have .ini files that aren’t lining up with your config.

What happens if you remove SD card and turn on?

Absolutely nothing is happening dose not turn on nothing

Its literally a copy paste of my sd and config it’s impossible for it not to work … mine works just fin

Are you able to switch it on and off or remove the battery?
Can you press Reset button the board?
Is the battery charged and/or can you check the battery voltage?
Does it make any noise when the board is connected to the computer?
Any noticeable burned or melted parts on the board or loose connections.
You’re not really giving us much to go on, the config may not be the issue but to find the cause we’re going to need more info and/or you’re going to need to try more things to narrow things down.