Having Trouble getting edit mode to work

I’ve just tried to make the switch to os 6. I cannot get edit mode to work on my saber, and I’m not sure why. I’ve downloaded version 6.7, and I’ve watched an hour long youtube video by megatooth, and I attempted to follow his instructions as much as possible with the exception of combining my tracks and common files. I’ve added the proper defines, and I’ve switched all but 2 of my blade styles to the os6 version. Fernando helped me trouble shoot on the facebook page, but we can’t seem to isolate the problem. It’s most likely something really simple, but I can’t find the issue with my untrained eye. The pastebin link is below if you want to see my config file. Fernando thinks its running the wrong prop file, but it should be running what is in the os6 folder right? Any help would be appreciated.

Let’s start by confirming the prop is correct. Remove or comment out this define and try to upload, what does Arduino say?


It uploaded successfully.

Then your OS isn’t 6. Download a new OS from here.

Close Arduino.
Unzip the new OS to a new folder on your computer.
Copy your current config into the /config folder for the new OS.
Open ProffieOS.ino from the new folder
Define your config in the new ProffieOS.ino
Add that define back
Upload and try out Edit Mode.

that’s so strange?? ok. give me a few minutes.

ok. did all that. didn’t work. i’m sorry!!

Remove that same define, what does Arduino say now?

upload successful

Then you’re uploading a different OS than you think. That define is required if you have


and Arduino won’t let you upload and returns an error without it.

In Arduino do ‘Ctrl’ + F and search “edit_mode”. Tell me if it finds it and what the line it finds says.

I’m running this on a mac. Will that make a difference? Also, I removed define ENABLE_ALL_EDIT_OPTIONS, not the FETT263 one.

I don’t know Mac, just do a find in ProffieOS.ino for “edit_mode” if ‘Ctrl’ + F doesn’t work.

Yes, if you removed that define the prop will not let Arduino upload if you have the FETT263_EDIT_MODE_MENU define.

It can’t find it. I’m so baffled by this, and I’m sure it something silly I’m doing. I’m only working from the 6.7 file that I just downloaded, so it should work. What else could I possibly be uploading?

I need to go pick up my kid down the street. I’ll be back in a few minutes.

You’re still opening the wrong OS then.

Close Arduino.

Navigate to where you unzipped the OS6 download on your computer. First go into the “styles” folder, do you see “edit_mode.h”?

If yes, put a copy of your config in the /config folder

Then launch ProffieOS.ino from that location, define your config and try again.

I’ll be logging out shortly and won’t be back on until the morning.

Your current issue is you’re uploading an older OS instead of OS6. You just need to find and upload OS6 with the original config above and Edit Mode should work, assuming you have the Voice Prompts in"common" folder.

Refer to this page

Will do. If I don’t see it. I’m going to delete all of the proffie files from my computer completely and start over. I’ll save my config file of course.

Thank you for your help and incredible patience!!!

You’re welcome. I’d recommend renaming your config when you try again. Do something like “myos6_config.h” so it’s more obvious when you define in ProffieOS.ino if it’s missing and when you try to find in /config.

You just need to upload the right version and you should be good.

It compiles and runs fine uploaded via OS6.7 on my MacBook. Make sure your previous OS version and the OS6.7 version are in their own separate main folders. What time zone are you? I might be able to look via Zoom but not tonight. Signed, a MacUser

1 Like

I’m just now seeing this. So sorry. Yes, I would love to zoom or something. I created a video to show my exact steps, but I can’t get it to upload here.

I’m just now getting back to this. Sorry. Work has been crazy this week.

I created a video showing my exact steps, and I tried to upload it here. It won’t. Is it ok for me to send it to you on FB messenger?