Font directory not found error

Problems uploading my config/ using zadig. When I connect my board with SD card mounted it says “font directory not found”. I have formatted my SD card and recopied the fonts over, reseated the SD card, double checked the spelling on my config to make sure it all matches with my SD - nothing. Same problem. My config has verified fine, my SD card works in my computer fine and I haven’t had this problem before, just on this upload. Any suggestions? Feeling defeated! :S

My config:

My SD card:

Is it just font directory not found or is it also SD card not found? What happens when you hook up to Tools > Serial Monitor in Arduino and type “effects”?

Just font directory not found. With the board plugged in, typed that in and pressed ‘Send’ - nothing happened.

Does anything show in Serial Monitor?

Shows nothing after I type in “effects”

Remove screenshot, its not needed.
Is your saber connected and correct Port selected?

Saber to the best of my knowledge is connected properly, and I only have COM1 available to choose from.

I don’t think your saber is connected, you either don’t have a data cable, or you didn’t set up the drivers properly. In which case, I think your error is because you didn’t actually upload a new config and your saber is looking for the default fonts.

Try these:

1 Like

I’ve used this cable for previous uploads and it has worked - though currently with this problem I haven’t managed any kind of upload. The moment I plug my board into my PC it just says in the crackly voice “font directory not found”. Should I get another cable just to try it out? Proffieboard isn’t coming up in my devices (using Windows 10).

Do you have a voice pack in the common directory?
Try removing DISABLE_DIAGNOSTIC_COMMANDS from your config file (and upload), then you can use the effects command to figure out what is actually going on.

Of course, if the saber isn’t connecting, and you cannot upload, then please try a different cable.

I do have the voice pack files in common. Removed that command from my config, tried to upload - came up with this error - C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hard - Pastebin.com

Another memory error? I have reduced it down three times, each time I reverify and it says it has worked/ verifies correctly and then comes up with memory issue again - I haven’t added anything extra into it.

After this error I went Tools>Port:“COM1” and typed in effects + hit enter, nothing has come up. It’s baffling as I have uploaded so many times before on multiple sabers but just hitting a blocker with this. Thank you for your help so far.

I don’t think you’ve uploaded, and the current programming is looking for an old programmed font that doesn’t exist on your saber.
You need to sort your drivers first, so that the board shows up as a Proffieboard to the computer, then Arduino Tools>Port should have your Proffieboard on a COM port, then you can open Serial Monitor and communicate with the OS. Then you can see what it’s looking for and not finding, and saying your error.

To sort the drivers is that the Zadig method to get ST32 up? Because if so I have been trying to reflash the board and I keep just getting the “font directory not found” even after flashing, and STM32 isnt appearing for me. I have reflashed my other sabers fine but this one doesnt seem to be working for some reason. When I hit the first button normally I would get a USB notification sound, but I’m getting nothing.

To manually put the board in bootloader mode, you need to apply power while the BOOT button is depressed, then release it.
So either:
Hold BOOT, press and release RESET, then release BOOT,
or alternately,
Plug in USB to just the Proffieboard end,
press and hold BOOT, plug USB into computer, release BOOT.
That should connect to the PC as STM32BOOTLOADER, and then you use Zadig to install the correct driver for it.
Once that’s done, you can unplug and re-plug USB to reboot the board into ProffieOS, and it should show up as a Proffieboard to the PC, which typically gets the driver installed automatically.
If not, check out this video:

Removing DISABLE_DIAGNOSTIC_COMMAND does use up some memory.
Because of this error, no upload actually happened.
I would recommend making a copy of your config file for later, then remove all presets except one, then try again. (Then later, go back to the config file which has all the presets, and DISABLE_DIAGNOSTIC_COMMANDS.)

Hmm I tried this both ways and both times I just got the crackly font directory feedback and no STM32. I have a new data cable arriving today so I’m going to see if it’s that.

Tried this and I am now getting this at the end of my failed upload after the count from 1-10:

Wait. So does the board show up as Proffieboard under devices and printers?
If yes, go-to details and look at the driver installed.
If it’s not usbser.sys, uninstall and let windows reinstall.
Once the driver for Proffieboard is correct, you should see it show up in Arduino under Tools>Port.
Then you can open Serial Monitor and type RebootDFU to get the board into bootloader mode.

This is an error inside of Arduino. I’m not sure if it’s significant or even relevant. If you post the whole thing (not just the last part) then we’d be able to see if your upload succeeded or not.

My guess is that it didn’t because it’s not supposed to count to 10. As soon as the board is found (in bootloader mode) it’s supposed to move on to the actual upload.

Did you select the proffieboard in arduino → tools → port?