"Font Directory Not Found" and "SD Card Not Found" on Two PBv3 Sabers w/ Same config

Hi Saber Community,

I am experiencing something very strange. I am using proffie OS 7.14 and this config: Config for OBI3 and OBI2 - Pastebin.com

and on TWO completely different sabers I am getting “Arc Directory Not Found SD Card Not Found”

Is there a way to debug what is going on here? Thank you for the support

One was working just fine. Then starting giving me the issue.

The other was also working fine then I installed a Bluetooth module (wired proper) and its freatking out. The speaker is making a buzzing sound. and no sound fonts work. I took a look at the SD cards and they both seem fine.

I tried different SDs.

What you’re hearing is “Font Directory Not Found” and ofc “SD Card Not Found”

In this case, the former is a red herring since the sd card itself can’t be found.

If the SD cards are working just fine in the computer and were working before, the classic advice would be to make sure the sd cards are formatted as FAT32 and to try reformatting and recopying the files, in case of corruption.

I would also double check and verify that these are indeed proffie v3 boards.

Following that, the Bluetooth could be an issue if you didn’t install the proper capacitor (saying you did it “correctly” doesn’t help much)

For the other, what did you change in between it working and not? Did you change the config or anything?

Your config doesn’t look overtly wrong (nothing that should cause this), but there are a couple oddities like enable save state and your buttons being reversed. You might want to try out ProffieConfig to take out some of the potential confusion there.

Let me know about the aforementioned and we can go from there. There’s a few different things this could potentially be, but those would be my first thoughts.

Thank you for your suggestions. When looking at the SD I do not see any issues. But I think you are on to something about them being formatted as FAT32

I will give it a shot. What do you mean by proper capacitor? I used a Shtok V2 breakout board witth RX pad to TX on Proffie and TX pad to RX on proffie. 3.3 Pad to SD 444v44 on proffie and GND to GND.


Okay so I did what you suggested and reformatted it and same thing.

However, the one with bluetooth. The speaker freaks out with a loud noise.

Why would it all of the sudden start doing that? It was working fine. Then arc directory not found?

First of all:

So, on one saber you added a bluetooth module.
Did you also re-program it?
Did you do anything else to it?
Adding a bluetooth module can cause problems with the 3.3v power, which the SD card relies on. If you remove the BT module, does it start working again?

On the other, what were you doing when this started?
Did you add a font? Did you re-program? Did you put the SD card in a coffee grinder? Or did it just start by itself?

IF you format the SD card, make sure to use the SD association formatter. ProffieOS currently does not handle GPT partition tables, and some other formatters likes generate GPT partition tables.

Also, you can try changing the SDIO speed from high to default when you program the board and see if that works better.

If you make a video or recording of the sound, I may be able to identify what is causing it from the way it sounds.

First of all thank you very much for your help.

Let’s focus on the one without Bluetooth for the sake of simplicity, which was working fine. Then all of the sudden “Arc directory not found as card not found”. The SD card is in good condition. But it is very strange that two boards from the same company are having this issue. Here is a video: https://1drv.ms/v/s!AvKhvcOdBcGdi4YWy0R3VEn4hk33Vw

Since the error began. I have:

1)reformatted the SD
2)reloaded the config
3)tried removing certain defines to see if it made any difference.

I really appreciate the help here. Is there a way I can plug it in and record the commands or something? Like a log or debug to see what is going on here?

It says “font”, not “arc”.

Did you use the SD association formatter?
Is the SD card using an GPT or DOS partition table? (If you don’t know, use the SD association formatter, and it will make sure the partition table is DOS, which should work with ProffieOS.)

There is something we can try. I’m not optimistic about it adding anything helpful, but you can add this define:


Then it will say an error message with an error code that may allow me to figure out what the problem is.

  1. I used SD Card Formatter . INK - quick format per Brian Conners suggestion Not sure what GPT or DOS portion table is honestly.

  2. I will try that now.

As well as the above, and if you haven’t tried this already, when you load the config, try selecting Serial only under the Tools>USB Type dropdown menu in Arduino. I’ve found on hilts that have exhibited this that it can sometimes help. That said, I’ve only known this problem to exist intermittently, not permanently. Which leads me to agree with the prof and others that your SD card formatting might the culprit here.

This is what I use:

I am installing: SD association formatter.

Which do i pick:

If you’re getting that dialog, you already have the sd association formatter, and it seem like that is what you are using.

So I reformatted and uploaded config and same problem.

I am taking the bluetooth off my OBI3 and will let you know what happens.

Thank you

Focusing on the saber without bluetooth. I am convinced the boards are a bad batch… They were both working fine. I did not change anything and then font directory not found…

Remove this define


Then upload.

Then keep your saber connected to the computer and go to Arduino > Tools > Serial Monitor

Type ‘effects’ and see what it prints out.

Then check your SD card to make sure the folders it’s looking for exist in the root of the SD.

If they do and it still gives error, then type ‘sdtest’ in Serial Monitor and post output.

Thanks FETT! So I removed disable diagnostic commands and opened the serial monitor this is what I got for the saber with bluetooth (new board - multimeter connections checked) which has been removed (the bluetooth) :

Also, when i plugged this one in I got a massive sound of distortion.

I am going to test my other saber now. This is what I got for the one without bluetooth:

Possibly a bad batch of boards?

Generally w/ a BLE module it’s recommended to add a 47uF (if my mind serves correctly) capacitor between 3.3v and GND in order to account for current spikes from the BLE module, since the SD is dependent on that 3.3v (among other things), it being drained by BLE could cause issues there. If you’ve removed it and you’re still getting the same issue though then that wouldn’t be the cause here. (Though that cap is still recommended)

That’s not new information than what we had before. The SD card just won’t mount, running sdtest or anything won’t work (or rather, won’t be useful) in this case.

Have you tried the define proffezorn suggested?

My thoughts as well. Both boards are doing this. As I just wrote I do think its possible there is a bad batch (no pun intended from the animated series by Disney)

The obi 2 night by KR with proffie V3 was working fine. Then stopped and gave me this error, out of nowhere randomly.

The obi 3 ELF is brand spanking new board from tritium was working fine, but then bluetooth came in and I got the same error.

For the record I am not trying to bad mouth anyone. Tritum is a great cost effect source for boards. However, I am not ruling out that I could have gotten a bad board(s). But I have little experience with this. Most boards I have installed have been fine (proffie V2.2 mostly) so i am not sure if a board initially works fine but then spontaneously gives me this error could qualify as a bad board. ie working fine… then NOT @profezzorn is this possible?