First ever proffie build

Hello all,
I’ve been working on my first proffie build so please go easy😄. After many attempts I’ve got the thing working, well SORT of working, Power is flowing, Sound is excellent and loud, switches are working, the test config I flashed (OS7.8) is working perfectly.
But the emitter led’s (there’s 8 of them) won’t light up. Stupidly I removed the resistor from the back of the connector is this the cause? I thought DATA1 already had a resistor built in?
It’s just the simple 2 button wire setup minus the recharge port, one main blade.

you can leave the resistor on the pcb even with data1 having a resistor. a couple in line arent enough to cause issues.

when you removed the resistor did you bridge the pads that the resistor was connecting? if not your data line wont be making a connection. what sort of pcb are you using?

Thanks i think you just solved my problem, you from aussie? Hey cuz, Im from NZ😁

1 Like

Hi again everyone,
A new problem has arisen, I connected the bridge and now it will only power on with usb connected, when connected audio works fine with battery inserted but only 3 of the 8 emitter Leds’s light up?? does anyone know whats going on, I’m pretty sure I wired everything correctly

Yeah mate, I’m from Queensland.


sydney here.


Kia ora korua (hello to you two) from Auckland New Zealand

Good at coding but suck at soldering🤣

1 Like

we all do at the start. get yaself a practice board and practice.

1 Like

Magnification is key.
Being able to see what you’re doing properly is important.


Thanks guys😁

1 Like

I’m having the worst luck right now, wired up a new proffie but the upload was interupted and didn’t complete at 95%! I followed Profezzorn’s instructions to hold Boot and press reset, I get a conformation beep but SMTP bootloader doesn’t appear. Repeated again but no go. Tried resttarting PC but nothing. I think I killed it😄
Can you please help me , Thank you

The buttons can be fiddly.
Try instead holding BOOT and then plugging the USB cable into the PC. Then release BOOT.
The key is that when the BOOT button is released, the power is already present.

1 Like

Hey NoSloppy thanks for this I’ll give it a try🤞🏽

Ok gave me a beep, what should I do Next?

Gonna Start over thanks NoSloppy

1 Like

The board beeped? Or do you mean the computer?
The board won’t make any sound at all when in bootloader mode.
If the PC chimed a sound that something connected, that’s good.
The Proffieboard should show up as STM32 BOOTLOADER in Devices and Printers.
If it doesn’t, make sure your cable is good, try a different USB port, or try a different computer.

Make sure you installed the correct driver (I’d just use proffie-dfu-setup as you just click it to run it and then done, or use Zadig.)

Hitting upload while in Bootloader mode simply means you are skipping the first step in Arduino’s programming process where Arduino itself reboots the board in bootloader.
Once upload is complete, the board should boot normally into ProffieOS, and show up as a composite device named “Proffieboard” in Devices and printers.

Full instructions:

Thank you for the assistance

If you really want to know how it works, read this: