Fett263 ProffieOS6 Prop (Button) File for 1 or 2 Buttons

I’m starting this thread to answer questions specific to my prop file. I have a dedicated page for setup, controls and defines here:

To answer the most common question off the bat, my OS6 Prop now supports 1 button and allows for all of the new functionality to run. I worked with sa22c to adapt his 1 button controls to the new OS6 features and have added a few defines to allow 2 button control to run similar to his OS5 file. The top of of the prop file or the above page cover all of the controls and defines.

There is so much new functionality in this prop please take the time to read through I have tried to document as much as possible but if you can’t find an answer for something in the prop itself or on the page above feel free to ask here.


I apologize if this has been answered earlier, I did try to search and wasn’t able to find any answers. I’m upgrading a saber to 6.5, and I put my tracks in my common folder. I also placed a few tracks in my track folder in the font. When I use track player or edit mode to switch fonts I’m finding that it isn’t playing every track. The file plays on my computer without issue and I’ve even deleted the file from the SD card and recopied it a few times.

Has this been an issue for anyone else?


Make sure the tracks are the correct format for ProffieOS. Just because they play on your computer doesn’t mean they are formatted correctly.

I like how multi blast is way easier to trigger and once I got the part with the quote actions changed and loop became an option it all went smooth. Zero issues.

FWIW kcrnalo1105, I found it easiest to just throw the tracks in the common folder (*You are putting them in the common folder in the SD, not the Proffie operational folder on the computer, right?) as a tracks folder, with each track outside of their folder and just renamed appropriately to the related font or character name with a brief clue. ie: Jedi Fallen Order Quote 1 is JFO1.wav and Rey’s quotes are Rey1.wav, Rey2.wav, Ep1Theme.wav for the songs, etc.

Thanks, his track issue was resolved in the OS6.5 thread, the tracks were not formatted correctly, which is almost always the cause.

Tracks can be in “font/tracks/” or “common/tracks/” or both for Track Player and Edit tracks. The difference is tracks in “common/tracks/” will play on all presets, if you have tracks you want for specific presets, like a character theme, you’d put them in “font/tracks/” and then they’ll only play in that font. Some users don’t want Luke’s theme to play on their Vader fonts, etc. but more generic tracks that you want on all presets you can put in “common/tracks/” to share across presets.

1 Like

Hi Fett, I posted this on Facebook, but am continuing here at your request.

My issue is with the Twist gesture in your Prop file. In the past I used the sa22c prop file with twist gestures for ignition and retraction. I wished to do the same with the Fett prop file as well. I’m encountering issues where if I do multiple twists in a row, the blade bounces in/out and vice versa, which makes sense from a code and “why wouldn’t it?” perspective. However, the sa22c prop file has code in it that prevents quick successive twist events (see line 439 for example), and I’d like to see that or some similar functionality in the Fett prop file if possible.

In this PasteBin link is my Config file for reference as well as a Serial Monitor output, The first three “twists” are spaced apart, the next several are close to each other and successive.

Thank you for your help on FB and for your consideration here.


This might sound blunt, but “then don’t do that”. Seriously though, the delay was purposefully removed during the OS6 Beta because users actually want to have quick succession retract and ignite and it prevented.
On the flip side you can very easily prevent it by doing twist correctly and intentionally. The motion is a rotation in one direction and quick rotation in the reverse direction back and forth ONE-TIME, like a single rev on a motorcycle. The output looks like you are twisting back and forth, back and forth over and over so the saber is doing what you asked it to. You’re free to add code to your copy but for users who actually want and intentionally do this action putting that code breaks it for them, whereas you can simply twist one time instead of multiple times and get your desired result.
Being a Jedi takes practice, so practice doing the gesture as it’s meant and you shouldn’t have any issues :wink:

Totally understood. I’ll try modifying it myself and if I break something, I’ll ask for help again. Thanks for responding!

You’re welcome.
Alternatively, you can just deactivate Twist On and use different gestures for ignition and reserve Twist for retraction only if you have trouble getting the gesture down.
Also, just for the record the gesture code in sa22c’s file is from the OS5 version of my prop, all of the differences are intentional and meant as improvements for OS6. Sa22c had just copied the gesture code from my OS5 prop into his.

*I’ll need to play catchup on the replies above but I had a suggestion/idea. Change the 2 button prop button combination to like a 3-4 click of power versus using Aux-Pwr for the built in battery meter call-up. More than once I’ve inadvertently copied a preset or entered volume menu because the mild difference in the commands is so similar.

You’re free to do what you want on your saber, I really, really dislike multiple clicks as controls, to me it makes it so much harder to use and makes it so much easier to get the wrong results. It’s necessary for 1 button (which is why I will never use), but I won’t implement on 2 button in my prop.

True. I just noticed you kept the option for the passive and preset change meter options so I’ll try those out first.

Hi @Fett263,

I just installed Proffie OS 6.5 on my 1 button saber and I must say it is absolutely fantastic and I really appreciate all the hard work that has come from the community to make this a possibility!

My question is in regards to the “Standard Controls While Blade is OFF”. I noticed both in the list of new functions, and while experimenting with my saber, that there is now an ability to Copy a preset on the fly (outside of edit mode) with a quadruple click of the power button with the last click being a hold.

There have been multiple times where I have accidently clicked the button 4 times thinking I only clicked 3 and my saber preset was copied and pasted over another one on my SD card. I noticed that this copy feature does NOT prompt for a confirmation and has pasted over other presets also without confirmation. I always have to take out the SD card and make fixes on my computer to bring the presets back.

I think a good solution to this would be to remove the copy on the fly feature and have it only accessible in the edit mode, otherwise leave the “on the fly feature”, but add in a confirmation prompt.

In the mean time before a fix is released in the next update, how would I go about removing this feature from the standard menu, while still having access to it in the edit mode? in other words, I like the copy preset feature, I just don’t want to have the ability to do it on the fly and risk using it on accident, I only want the feature to live in edit mode.

I’ve tried searching The Crucible for answers to this 1 button saber question, but I haven’t seen anyone else talking about it. Please let me know if a solution is possible. Thank you!

This is why I never use 1 button sabers, the controls are a total PITA to me. That being said,
Copy Preset doesn’t paste over another preset, it Adds a copy of the active preset. The other presets are not touched. You can use Delete preset in Edit Mode or ProffieOS Workbench to remove.
There is already a prompt, if you’re not hearing then you may be missing the sounds that are required for my prop or didn’t set up the “common” folder per the documentation.
If you want to disable the ability on your personal saber, just comment out line 4598 in my prop:

        if (menu_) return true;
        return true;

add "//" in front of CopyPreset(true); like so:

        if (menu_) return true;
        return true;

this will disable the function.

Its not something that needs to be “fixed” from my POV, but you are free to change on your version to your personal liking and needs.

1 Like

Thank you so much! That worked exactly how I was hoping it would!

I’m not sure if I may have configured something differently, it looks the same, but before I put in this fix the saber was overwriting my 1st font with a copy of my last font on my SD card anytime I hit the power button 4 times. If I happen to do it multiple times it would erase my 2nd fond, 3rd, and so on all with copies of my last font.

I was hearing a voice prompt saying “Copy Preset” but I wasn’t hearing the “confirm?” after that like I do when I’m in edit mode.

Regardless, this worked great, thanks again for the help!

It couldn’t have deleted other presets, the copy is made after the current preset so your 2nd would now be 3rd and so on.
“On the fly” doesn’t have a secondary prompt, it just says Copy Preset to confirm it copied. If you don’t need it then just keep that line commented out.

It was deleting them or perhaps hiding them. At least from my “Select Preset” wheel. After the copies were made I went through every sound font from first to last and the ones that received copies took the place of the old fonts.

For example, my “insidious” preset (the first font on my saber) was removed completely from my “select preset” menu once the “smooth fuzz” preset (last preset on my saber) copy was made.

When I went into the SD card the files themselves were not deleted, but I couldnt access the font or preset through the “select preset” function or even through the “next font” option going all the way through each preset multiple times.

No idea how that’s possible unless you were doing something other than copying the preset. Are you sure you weren’t changing the font? There’s an on the fly font change as well, copy presets cannot remove presets but if you changed the font you might not realize the preset is still there. We’d have to see your presets.ini file from your saber after the change to diagnose, but CopyPreset() cannot do what you’re describing.

Ah I see, hmm yeah i’m not sure what it was, but I don’t think it was just changing the font. I would have certainly found the missing ones if that’s all it was doing.

That makes sense though if you were indeed changing the preset’s font, no?
If you had Insidious and you replace it with SmthFuzz, then Insidious is no longer played in the “select preset” list.