Error Compiling

my .bashrc is usually the target.

I didn’t think you needed sudo to edit that… :man_shrugging:

Either way… it is the magic word to get what you want.

I’ve got a new problem. I made a mistake and deleted proffie package from arduino Ide ;but, I found it in my arduino folder. How can I install this back in arduino?

Same way you installed it the first time?

Is it just me or my os arduino 14.7 disappeared from my zip file?

I’d like to answer this, but I don’t really understand the question.

I just don’t have a proffie os app in my file from proffie os that I down loaded from your web page. I have a proffie os ino file ; but, missing the app to open it up.

Arduino is a separate program. I suggest you download version 1.8.19, reinstall the Proffieboard plugin etc… all in the instructions profezzorn linked above.

^To clarify, proffieOS.ino is the launch that then opens up Arduino with the Proffie sketch so you can then load your config to the board. Thus @NoSloppy’s suggestion and I’ll mirror that Arduino 1.8.19 is far superior for our needs here than the newer version. The new readout and some other things just suck. Are you on a pc, Mac, what?

An INO file is related to Arduino Sketch which is a program written for Arduino boards using the Arduino programming language. The Arduino programming language is based on Wiring; and it is similar to C/C++. Arduino Sketches are saved with a . ino file extension and are used to control Arduino circuit boards.

I’m sorry for breaking the rules.

You should remove the pics as per forum rules.
Nothing is wrong in those pics other than you don’t have your CONFIG_FILE defined as per the text in the big box above the line


What’s your config file named? For example mine usually say something like OS7_FallenOrder.h and per @NoSloppy’s reply you want something similar to that stated in Arduino. From there removing the 2 // marks enables that line for recognition. Just be sure you only ever have one config listing uncommented.

As an example in my case it would be something like

#define CONFIG_FILE "config/OS7_FallenOrder.h"

Where “…YOUR_CONFIG_FILE_NAME_HERE.h” is replaced with “…OS7_FallenOrder.h”

I always suggest people DO NOT alter any of the factory naming examples and simply copy the example and paste it directly below the example and edit their config name in, then hit Save on the Arduino Toolbar.

So Arduino will then read (my setup being an example here)…
Hover over this grey box and scroll to see the full window.

ProffieOS_7.14 02_05_2024: Control software for lightsabers and other props.
 Copyright (c) 2016-2019 Fredrik Hubinette
 Additional copyright holders listed inline below.

 This program is free software: you can redistribute it and/or modify
 it under the terms of the GNU General Public License as published by
 the Free Software Foundation, either version 3 of the License, or
 (at your option) any later version.

 This program is distributed in the hope that it will be useful,
 but WITHOUT ANY WARRANTY; without even the implied warranty of
 GNU General Public License for more details.

 You should have received a copy of the GNU General Public License
 along with this program.  If not, see <>.

|  You can have multiple configuration files, and specify which one |
|  to use here by removing the two slashes at the beginning.        |
|  **NOTE** Only ONE line should be left uncommented at a time!     |
|  Add the slashes to any that you are not using.                   |


//Sabertrio Hilts:
#define CONFIG_FILE "config/OS7_FallenOrder.h"
//#define CONFIG_FILE "config/OS7_Survivor.h"

// #define CONFIG_FILE "config/default_proffieboard_config.h"
// #define CONFIG_FILE "config/default_v3_config.h"
// #define CONFIG_FILE "config/crossguard_config.h"
// #define CONFIG_FILE "config/graflex_v1_config.h"

//So-on and so-on for the rest of the sketch.

So going back to the prior statement you will notice the active config I am loading up has the uncomment bars, the // taken out. All other config lists are disabled via commenting out using //

Side note: Since I use more than one version of ProffieOS I’ve inserted which specific version I have open as part of the first line.

So instead of it saying

ProffieOS: Control software...

It now says

ProffieOS_7.14 02_05_2024: Control software...

but that’s up to you if you want to do that sort of thing.

*I really suggest trying to have a remote-in lesson still. It helps.

One of you please do me a favor. Please download the proffie os 7.14 and unzip the files and tell me what you see. I went to my sister’s pc and downloaded the 7.14 and it’s the same. No way to open Arduino proffie os.

You need to have Arduino IDE installed on your computer (just choose MSI Installer underneath Windows downloads, and once you’ve downloaded it you can run that installer), which I don’t think you do at the moment since it seems you opened the “ProffieOS” file with your web browser. If when you try to open the ProffieOS file it automatically opens your web browser and you have arduino installed, try right clicking on it and choosing “Open With…” which should give you an option to open Arduino.

The ProffieOS file you have there is the correct one, so you have what you need on the computer already as far as the Proffie OS, but your missing the software needed to actually put it in the board (that’s what Arduino IDE is for)

I’ve got most of my problems fix ;but, I’m still getting this.
C:\Users\DaJo5\Downloads\ProffieOS-v7.14\ProffieOS\ProffieOS.ino:53:2: error: #error Please set CONFIG_FILE as shown above.
53 | #error Please set CONFIG_FILE as shown above.
| ^~~~~
C:\Users\DaJo5\Downloads\ProffieOS-v7.14\ProffieOS\ProffieOS.ino:57:10: error: #include expects “FILENAME” or
57 | #include CONFIG_FILE
| ^~~~~~~~~~~
C:\Users\DaJo5\Downloads\ProffieOS-v7.14\ProffieOS\ProffieOS.ino:617:10: error: #include expects “FILENAME” or
617 | #include CONFIG_FILE
| ^~~~~~~~~~~
C:\Users\DaJo5\Downloads\ProffieOS-v7.14\ProffieOS\ProffieOS.ino:621:10: error: #include expects “FILENAME” or
621 | #include CONFIG_FILE
| ^~~~~~~~~~~
C:\Users\DaJo5\Downloads\ProffieOS-v7.14\ProffieOS\ProffieOS.ino:625:10: error: #include expects “FILENAME” or
625 | #include CONFIG_FILE
| ^~~~~~~~~~~
C:\Users\DaJo5\Downloads\ProffieOS-v7.14\ProffieOS\ProffieOS.ino:683:10: error: #include expects “FILENAME” or
683 | #include CONFIG_FILE
| ^~~~~~~~~~~
C:\Users\DaJo5\Downloads\ProffieOS-v7.14\ProffieOS\ProffieOS.ino:1560:10: error: #include expects “FILENAME” or
1560 | #include CONFIG_FILE
| ^~~~~~~~~~~
exit status 1

Compilation error: #error Please set CONFIG_FILE as shown above.

Does this help?

I did exactly what this said and this is what I got
Arduino: 1.8.19 (Windows 10), Board: “Proffieboard V2, Serial, SDCARD (SPI), 80 MHz, Smallest Code”

ProffieOS:57:10: error: #include expects “FILENAME” or

57 | #include CONFIG_FILE

  |          ^~~~~~~~~~~

ProffieOS:617:10: error: #include expects “FILENAME” or

617 | #include CONFIG_FILE

  |          ^~~~~~~~~~~

ProffieOS:621:10: error: #include expects “FILENAME” or

621 | #include CONFIG_FILE

  |          ^~~~~~~~~~~

ProffieOS:625:10: error: #include expects “FILENAME” or

625 | #include CONFIG_FILE

  |          ^~~~~~~~~~~

ProffieOS:683:10: error: #include expects “FILENAME” or

683 | #include CONFIG_FILE

  |          ^~~~~~~~~~~

ProffieOS:1560:10: error: #include expects “FILENAME” or

1560 | #include CONFIG_FILE

  |          ^~~~~~~~~~~

exit status 1

#include expects “FILENAME” or

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

Arduino still thinks there is something wrong with it though. Can you cut-n-paste the CONFIG_FILE define from ProffieOS.ino so we can see it? What editor did you use to change the define?

Are you sure you removed the 2 slashes from the front of the line?
// #define is wrong.
#define is correct.

Here you go