Edit mode on one button?

I’m having an issue with entering edit mode on a one button. didn’t realize this saber I bought only had one button, so I’m trying to figure out the control differences. I’ve got most of them down, but I can’t get into edit mode for some reason. I’ve tried both long pressing and double clicking with a long press, and neither enter edit mode. I don’t even get an error code. I entered the define the same way I have on all my two button ones that have worked in the past. I’ll stick my config on here. any ideas? thanks!

It looks like you’re using the wrong prop file. I don’t believe the BC prop supports Edit Mode; you’ll want to use Fett263’s prop.



And Edit Mode should work. (also check that the fett263 prop is included in the prop folder)

Another thing you should do is remove

That line’s not needed.

You’ll need to change a few of the BC defines at the top of the config too for gesture controls, since those won’t work with the Fett263 prop. The necessary defines for gestures (along with the controls) should be listed at the top of the fett263 prop, so pick the ones you want and replace the BC defines.

1 Like

See Set Up Instructions, Controls and Defines for my prop here:

More info on Edit Mode here:

1 Like

great thanks, guys. so, after changing the prop include, are the only defines that I need to change the ones that indicate BC before them? and I need to change them to the fett specific defines?

so, change:

#define BC_THRUST_ON
#define BC_TWIST_ON
#define BC_TWIST_OFF


#define FETT263_THRUST_ON
#define FETT263_TWIST_ON
#define FETT263_TWIST_OFF
#define FETT263_FORCE_PUSH

anything else look problematic?

1 Like

hey guys, I’m getting this error code now:

In file included from /Users/andrewdavenport/Desktop/ProffieOS/ProffieOS.ino:644:
/Users/andrewdavenport/Desktop/ProffieOS/config/TheMaraJadeConfig??.h:39:10: error: #include expects "FILENAME" or <FILENAME>
   39 | #include ".../props/saber_fett263_buttons.h”
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
exit status 1

Compilation error: #include expects "FILENAME" or <FILENAME>

You have three periods () where there should only be two. Perhaps this is because you’re not using a plain text editor and instead one that auto expanded the two to three?

It should be #include "../props/saber_fett263_buttons.h”

oops. Unfortunately still get the code, though.

In file included from /Users/andrewdavenport/Desktop/ProffieOS/ProffieOS.ino:644:
/Users/andrewdavenport/Desktop/ProffieOS/config/TheMaraJadeConfig??.h:39:10: error: #include expects "FILENAME" or <FILENAME>
   39 | #include "../props/saber_fett263_buttons.h”
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
exit status 1

Compilation error: #include expects "FILENAME" or <FILENAME>

Oh, i didn’t realize. Your second " is a fancy Unicode “ curvy thing. (It needs to be a plain double quote)

Also likely from editing using a rich text editor. You should use something like Sublime Text.

that’s what I’m using. I just copied the one you sent, and I still got the code. I just typed it in manually and got it to go through. I think you were right about the quotes.

now the board is overflowed by 17000 bytes, though?! yikes. I don’t have that much on there. should that have taken up that much space?

Yeah, I copied it from yours initially and then edited it, but missed the quote, sorry.

Fetts prop and features require a lot more flash memory. You can disable some of the features to try and get it down, but his prop just takes up more space. Or remove your own presets

I have another two-button saber that is set up basically the same with the same profiles that fits. I’ll have to poke around to see what is different to see if I can save some space. thanks for your help.

1 Like

You’re mixing syntaxes and have several styles that aren’t Edit Mode enabled. I recommend using my config tool and generating all of your styles from my OS7 library. When you mix style versions and syntaxes it wastes a lot of memory.
Using my config tool with option styles for Edit Mode from my library you can fit a lot more on the board. Watch the videos at the top and read through the instructions and selections.

thanks. good to know and makes sense. a lot of times when I get sabers, I’ll mix and match what it already has on it with my own styles. I also added a couple from greyscale fonts. pretty cool and unique styles and fonts, but I think they are taking up a bunch of space.

Greyscale styles will take up a lot of additional memory, I created optimized versions in the library that will save a lot more memory and are compatible with Edit Mode. If you use the library to generate all of your styles the config tool will typically allow you fit much more, especially if you use the “option” styles and style argument features with optimized styles.

See first post here, I talk about the Greyscale styles specifically:

this is great. thanks.