Desktop does not recognize Board, all common solutions attempted

Hey all, hopefully this will be the last time I come here to take rather than give… but this issue has had me floored for the past several weeks. Please save me from a nasty teardown!

Out of the blue (or so it seems), Windows 10 has stopped recognizing the Proffie STM32 Bootloader when plugged in via USB. Symptoms include:

-Computer chimes when it is plugged in but does not appear in My Computer screen or Device Manager.

-Port appears sporadically in Arduino, but still refuses to flash regardless if the port appears or not.

-Multiple USB ports (directly into PC, no hubs) and cables (all verified previous to issue presenting) attempted.

-Retry of Zadig failed, although the correct driver was confirmed.

-Issue is present regardless of which OS (5.9, 6.3, 6.5) is tried.

-Complete un/reinstall of Arduino and all drivers unsuccessful.

The ONLY fix so far has been to manually force Bootloader via the buttons on the board. This also seems sporadic, but that may be due to me not always pushing the buttons in the correct order as I have big hands/fingers.

The issue here is that not only is it inconvenient to need to manually bootload every time, but I made a rookie mistake on a build I just completed (custom length blade, didn’t define correct px count before finishing build) and disassembly to get back to the buttons to fix it and subsequent reassembly will be hell on earth. I’d much rather spend those hours diagnosing and correcting what is obviously a bug somewhere that I can’t sniff out. Let me know where to start :pray:t2::blush:


I remember you posting this vid when i asked abt this on Facebook but nothing in here worked. If I remember, everything was already set correctly according to Fredrik’s video.

I’ll go upstairs in a min and go through everything on here again step by step for good measure though and get back to ya.

4:30 is where it the fix really starts, then pay attention starting 5:50, with the important driver delete at 6:30

I started where you suggested at 4:30. Did the ‘remove this device’ and just like for Frederik it came right back. It did the “windows is setting up this device” then got the “your device is ready to use” and Proffieboard showed up in the devices and printers panel. I checked the settings like he did and it showed correctly like his did, see photo 1.

However, it doesn’t show up in device manager under USB devices. See photo 2. The only thing that shows up there is the device that controls my case lighting in my PC.

Disappointing! Let me know what’s next or if I need to tag the big guns in. Appreciate it as always bro!

Oh also, I don’t have that STM32 STLink item in devices/printers or device manager. Not sure if that means anything to you.

I would certainly try without other devices and drivers installed to see if there’s conflict.

As far as I know, that ASUS driver was always there. I can try disabling it.

On another small note, I just plugged in a completed saber that I know for a fact never had an issue before and it is still not showing up in Dev. Mgr. Guess that rules out hardware-level issue.

I’ll get back to you on disabling the ASUS driver in a min.

*You’re not “taking”, we’re all "paying it forwards. We all start somewhere and got help, so now it’s our turn to help.

I just went through similar on a friend’s pc. He ran Zadig more than once (by accident) when he was only supposed to run it the first time and the first time only. Mac users don’t need Zadig and pc users should only ever run it ONCE. First I put his config in cloud storage and then wiped the computer completely clear of all Zadig, Arduino, and Proffie, the same as I recently did with my Mac to clear an issue. After clearing the computer I went in and searched for his config title, Arduino, Zadig, and Proffie just to be sire and caught two files in documents. They seemed innocuous but remembering similar advise before from @NoSloppy I deleted those also. Ran a full shut down and restart and final checked for anything else missed. Then FIRST REMOVING THE SD CARD, I connect the cable to the board, WITHOUT ANY programs installed did a Boot/Reset and got the SD Card Not Detected bit (success!?). Since I got that I simply disconnected the board, NOT PUTTING THE SD BACK IN, downloaded and redid all the programs from scratch. Brought them up, edited in the correct parameters and config name, ran Zadig ONCE, connected the board (STILL WITH NO SD CARD) so only the cable was the power source and ran Boot/Reset a final time. Note, without the SD the “board” doesn’t appear but the confirm and upload success indicator is the “SD CARD not found” bit at the end. From there I disconnected the board and used SD Formatter separately for the SD card. Put all that’s in there (but back up ALL YOUR FONTS FIRST IF YOU DON’T HAVE A BACKUP) in the trash, delete the trash, then run SD Formatter. Once you get the “OK” just drop and paste all your font files into the SD and when done eject the SD. Put the SD in the board, put the battery in, and it should start right up.

Maybe I got lucky but it worked the same as it did for me on my pc last month so hopefully this works for you with it written out.

Keep in mind, the boot/reset buttons are not available, although I don’t think that’s going to be an option anymore.

I can try everything Shane said with another board. If that fixes it I should be golden with the build I don’t want to tear apart. Going through and trying what he said now.

Trying this now. How did you make sure you had purged all the STM32 Drivers?

I can’t find the specific post-link right now that we found but the steps I used were from one of these in the Open Source FB group on how to clear them. @NoSloppy could probably answer quicker since he can find those topics quick. Sorry not able to help w that part. Here’s the “multiple zadig” FB search line I bookmarked. @profezzorn may be able to share the step by step also.

*Nate, I think I remember it, just force the upload anyhow. It worked in what I had to fix.

Opinion, get a Mac. :wink:

First of all, it can be really hard to find the right device in the device manager, so don’t use it. Instead go to Settings → Bluetooth and other devices, then on the right side, under “related settings” click “Devices and Printers”.

Devices and Printers should show something when the proffieboard is connected. If it’s in bootloader mode it should show “Proffieboard”, and if not, it should show “Proffieboard”. If something else shows up when you plug in the proffieboard, then there is a driver conflict of some sort.

Also, from “Devices and Printers” you can right-click stuff and find the drivers to see if they look good or not. Since you seem to have a problem with bootloader mode, it would be best to put the board in bootloader mode, see what show up, and then check the drivers on that.

Now, it seems like you might have multiple problems, which is usually more of an electrical problem. Like, maybe something is causing the board to crash every so often? Another thing to check would be the SD card. Bad SD cards can cause a lot of really weird problems, including board crashes…

1 Like

Hey Fredrik, thanks for jumping in for me. Remember last week when I asked about the data pins not working (WS2811 vs WS281X issue) and mentioned that I had another issue to run by you? Here we are lol

Reading over your post above you said-

If it’s in bootloader mode it should show “Proffieboard”, and if not, it should show “Proffieboard”.

Is there a typo in there? It’s 12:45am where I am and I’m pretty exhausted, so it’s entirely possible my eyes aren’t working right. As I see it though, it’s saying it should show the same thing whether in Bootloader or not. It definitely shows up in this menu but Arduino won’t allow me to flash (gives the 1-10 count thing in the compile monitor and then stops). This happens regardless of whether or not there is an SD card attached. I can plug a totally empty board, no SD, not wired to anything (the one I am currently using WAS flashed if that makes a difference, if so, I can try a 100% brand new board), and same result.

I’m currently stripping out every last trace of anything labelled “proffie”, (except for my fonts ofc), “zadig”, and “arduino” (boy howdy that took some doing) from my machine as was suggested above.

If I force bootloader mode with the buttons, it works. Port doesn’t show up but I can flash. And as far as I can tell, the driver that Zadig pulled was correct. If that’s my only solution though, I’m in for a hellacious teardown. Not to mention that in a perfect world here, this -shouldn’t- be happening.

The only other thing I can -possibly- think of is that both of my known good cables crapped out at once, but idk how that would be possible. I haven’t observed any board crashes; like I said I can plug in a totally naked board and have the same issue.

Now that I have (as far as I can tell) ripped out every trace of arduino and Zadig, I’ll restart and plug in board again, see what it says, and post a screenshot. I’m thinking next step after this is a Windows Reset to, say, a month ago (if possible). And for what it’s worth, if you didn’t catch it above, I followed your video and everything looked correct except it wouldn’t plug and go; it needs bootloader button press.

Sorry for the soliloquy. Just want to give you as much info as possible to avoid wasting your time with back and forth comments. Let me know what, if anything, I can target specifically to show you so you’re up to speed. Might call it a night here shortly, but if so I’ll get back to you asap tomorrow. Thank you SO much!!!

If I force upload, it works without a port as long as STM32 Bootloader shows up in Device Manager. It’s done that since Brian talked me through this last week and suggested the same.

And I’ve used macs in the past… To be honest, as a semi-pro IT nerd, I’d rather suck start a blaster :rofl:

Yep, the first one is supposed to say “STM32 BOOTLOADER”.

Do you have the right port selected in Arduino → Tools → Port?

Oh, I see. So this means that the bootloader driver is fine, but the port driver might not be. The best resource for checking the port driver is the video posted earlier in this thread.

If you can flash, then it’s probably not a cable problem.

I had this issue before, would have to do the research again, but IIRC, there is manual driver deletes and registry editing.

TBH, it’s just easier to redo windows.

There should be no need for that. Uninstalling or swapping drivers is pretty easy. IF that is the problem.

1 Like