Config File doesn't upload to the board

I’ve been trying to add a soundfont to my Darksaber and I followed like 5 different tutorials and none of them worked for me, I asked Reddit and I don’t think I explained well, so, tell me what to send and I’ll follow the exact directions. I just want a new soundfont on my saber. Maybe in OS7 or OS7.something you guys can make it a little easier. Thanks

OS7 is in Beta, if you’re new to Proffieboard I would not recommend starting with a beta. Use OS6.8 and learn the basics, then when OS7 is releases you can update.
We need more info to help. If you haven’t already try this page. Start at the beginning, read everything and do it one step at-a-time. If you get stuck at a step let us know exactly where you are and what trouble or questions you have.

If you’re at the upload stage (after doing everything preceeding) and getting errors we need your config and the full error message. It’s easiest to use and share with us.

Copy that :+1:

So I did everything step by step and when I hit upload it went up to 62% and then it said error code 74. I then switched up cables and now it just counts to 10 and says “done uploading” and the board won’t turn on or make a sound.

If an upload is disrupted, then you end up with a bad programming, and most of the time, that means that ProffieOS doesn’t work anymore. That means that no serial port is available for arduino to talk to, and it also means that arduino can’t tell the proffieboard to go into bootloader mode.

However, proffieboards can be put into bootloader mode manually, and once properly programmed, everything should be back to normal. Here is how:

I did that and now it just says “font directory not found, sd card not found”. Sometimes when I check if it’s connected it says either Proffieboard or STM32 BOOTLOADER. what should I do now, I haven’t changed anything in the sd card except for the config_top.

If it says “sd card not found”, then the sd card is either corrupted, not inserted, or you selected “proffieboard” instead of “proffieboard v2” when you did the upload. (Or I suppose something could be broken.)

It’s also sometimes possible for the sd card to get stuck, in which case you need to make sure to remove USB and battery power from the board and try again.

But does it matter if it’s called bootloader or proffieboard in my settings?

Normally it should only come up as STM32 BOOTLOADER if you press the boot button. If it comes up as STM32 BOOTLOADER without that, that’s a bit weird. It could mean that you have a stuck boot button. (Or maybe the programming of the board is so broken that it just starts in bootloader mode instead.)

I did everything now it says this:

This just says that it can’t find your config file.

Ok so I managed to fix the problem with the config not found but now it just won’t upload, I do everything as it says in the videos and it still won’t upload.

Follow Fett263’s post above.

So what error message do you receive?

None, it just doesn’t upload to the saber, the sound fonts remain the same and the settings remain default.

If you have KEEP_SAVEFILES_WHEN_PROGRAMMING in your config file, remove it.

I don’t have it in my config, this is what I have. This is my config file starting here: // ProffieOS6 Config File#ifdef CONF -

I tried to upload this but it says “font directory not found” again.

So what does the serial monitor say?
If you need to, remove DISABLE_DIAGNOSTIC_COMMANDS from your config file and re-upload. That way you can use dir, pwd and effects in the serial monitor to see what it’s trying to do.

If you’re using my prop you need to include the “common” folder on your SD card and in your presets per the Set Up Instructions, and since you’re trying to use Edit Mode this is doubly true.

Your presets should be

{ "font;common", "font/tracks/track.wav",

If you’re using styles from the OS6 library you should keep the comments section with the style code that the library generates in each preset, this contains information about the style for editing, usage and troubleshooting and does not affect any memory used as it’s ignored by the compiler.

So I tried both of those, and it still says font directory not found