Config File doesn't upload to the board

It may sound a bit weird but maybe you should try to go step by step.

I suggest you to exclude all soundfonts by commenting them out // …// and leave only 1 Soundfont you are sure it works. You can even make a pretty empty testcopy of your config.

then try to upload this config and look if it works.

in the next step you add your new Soundfont to the Config so that you only have 2 Soundfonts… and so on.

Its kind of debugging-style… but by this “step by step”-method i got best results in learning Proffie-OS.

1 Like

Make sure the folder on your SD is exact same soelling and case as what youbput in your config AND make sure there aren’t multiple subfolders in the font folder for different boards. Some font makers will include multiple boards in the main folder, you need to just use the Proffieboard folder as the font.

I checked for other folders, I didn’t find any, I have attached screenshots of my SD Card and my Config file,

Screenshot 2023-03-24 181045
Screenshot 2023-03-24 181056

Delete the presets.ini and presets.tmp files off the SD card and try again.
If you still get FontDirectoryNotFound, make sure you are uploading the config file you think you are by making an intentional error, like type some junk zusnfdgluzsfdlgjnb .save and hit Verify in Arduino.
If it still compiles, you are pointing to the wrong config file.

Ok, I did that now I’m getting this error message Arduino: 1.8.19 (Windows 10), Board: "Proffieboard V2, Serial + Mass Storage + W -

That should be pretty easy for you to figure out. Clearly the config should not have a line that says “THE MAIN BLADE STYLE GOES HERE,”

Where did that come from? It was not in your config file before.
Maybe it’s a template remnant or something, but it’s likely supposed to be replaced…with what it says.

I checked the config and it’s not there

Then either you edited a config file named “mysaber_config.h” and haven’t saved the changes before Verify/Upload, or you are not uploading the config file you think you are.

According to the error, it is trying to upload a config file named “mysaber_config.h”
Double check the #define CONFIG_FILE line in ProffieOS.ino which you open in Arduino.
It should show the config file you want to use as the only file not commented out with 2 leading slashes //

I tried it in the Arduino 2.0.4 and I fixed the first problem now I’m getting this In file included from E:\config\ProffieOS\ProffieOS.ino:563:E:\config\ProffieO -

Look at the end of the style it’s complaining about in the error :wink:

I’d need to see what the config file looks like now in order to help figure it out.

Also, if you really have

 48 | Preset presets[] = {  //2022.7.25Ôö¼ÓΪ23Ì×ÒôЧ

I’d be curious how that got there

// ProffieOS6 Config File#ifdef CONFIG_TOP#include "proffieboard_v2_config.h - new config after I removed whatever that was

The first style is definitely messed up at the end. It looks like this:


There is no way there can be two () in the same style line.
Not sure where the Black>>>>() came from.

In file included from E:\config\ProffieOS\ProffieOS.ino:563:E:\config\ProffieO - here’s what I get now

So what did you change?

All 3 of your presets have a problem with ‘Black’ at the ending.

Start with the second preset, ‘Ronin’. It ends with:
InOutTrL<TrWipe<800>,TrWipeIn<800>Black>>>(), which is missing a comma before ‘Black’. So it should become either
OR, you omit the ‘Black’ since the Color When Off has a default of Black anyway so it could become just

It seems like the “invisible” default from the end of that InOutTrL that got pasted onto the end of the other presets somehow, because ‘Darksaber’ and ‘FallenV1’ presets both end like profezzorn said, with an extra Black>>>().

So I did what NoSloppy said and now it says Font Dir not found. Here is the config // ProffieOS6 Config File#ifdef CONFIG_TOP#include "proffieboard_v2_config.h -

Do you have a “common” directory on your sd card?
Does it have a voice pack in it?

Yes and Yes