Clicking Sounds… I don’t even understand. Is this just normal? It’s happening on 2 brand new proffie sabers. *Read further to see troubleshooting steps taken*

Clicking Sounds… I don’t even understand. Is this just normal? It’s happening on 2 brand new proffie sabers. Read further to see troubleshooting steps taken

I need to know if I’m just being crazy, or if the soundfonts I’m using just inherently have (clicking) sounds in them.

I have a Sabertrio Senza, and a Return of the Jedi Luke V2 TXQ saber. Both of which are brand new, and I got them within the last few months. I can confirm that both sabers make extremely brief clicking sounds during intervals of the hum, or swings. Flipping through edit mode, also results in the same things.

So Proffie sabers and soundfonts just sound like this?? I’ve read tons of boards trying to troubleshoot, and I’ll go ahead and list everything I’ve tried.

I’ve tried pretty much everything to troubleshoot.

*Turning down the volume and insuring that the config is set to the default volume.

*Formatting the SD Cards properly, and using multiple different brands of SD Cards.

*Using the SD Card tool to Format rather than the operating system on my computer.

*Installing different configs with simple blade styles.

  • Adding soundfonts in brand new folders, and adding the most optimized soundfonts to my saber only.

*Checking the serial monitor, and doing an SD test. I can confirm that I am receiving audio underflow messages.

I don’t really know what to do at this point guys. I feel like I need insight from people who have proffie sabers. If there is a problem.

I don’t think it’s possible that both would have bad speakers.

What version of ProffieOS are you using?
Can you post a video so we can hear what it actually sounds like?
Have you tried running sdtest to see what it says about your SD card?

I’ve experienced hearing this also with some fonts. A very light and mild “tick” that you hear best if the saber is just sitting at idle and humming and it happens at a regular interval. Based on that and feedback from @NoSloppy it ended up being the wav files and how the sound didn’t meet at the beginning/end where it loops not being an exact match in the level. It may be worth a look, IIRC he put together a video of how to detect and edit the sound to prevent it but I cannot find the link right now.

Does it do it only on certain fonts or all fonts? If it’s only certain fonts, it could be clipping in your audio files. Fonts from the major fontmakers shouldn’t do that, but other, more obscure fontmakers may not know how to avoid that. I’ve come across quite a few that I had to clean up to stop that. Should not happen with a purchased font, but it unfortunately does.

Is this a cross post from the FB group where the issue has been solved by removing the bmp files?

I think it is.

Cool, yeah I saw your reply and went “…duh?” so I also asked the OP in the group topic if it is the same to notate it here.

*On a related note, we really should have users mention that a topic here is also posted in the FB group(s) so going forwards it’s easier to track stuff.

@Jedemessiah So I don’t forget, Welcome to The Crucible. :smiley:

1 Like

Well could someone post the FB post at least?
Are you saying this clicking seemed to be linked to having .bmp files in the font folder?
And now it’s “fixed” by removing them?

Can’t paste the link for a single topic for some reason. Check the group under user “Jade…” IIRC.

On a desktop browser, if you click the little grey timestamp link in the post, it’ll open in a dedicated view. That URL can redirect people directly to the post.

On mobile, there’s a 3 dot menu including copy link option.

To bring this thread up to speed, (and continue the confusion?) apparently removing BMP image files from a common font folder “fixed” this. That doesn’t make much sense.

I have a strong suspicion it is more likely having to do with using Sabertrio’s modified ProffieOS, and then trying to mix and match stuff with an official ProffieOS version.

There are a few possibilities where BMP files could matter:

  1. The extra files could make it take longer to open audio files, creating underflows when we open a new file.
  2. If the display code is active, it might be opening and reading those files, which could theoretically cause audio underflows as well. (Kind of depends on the images actually.)

But it could of course also be some other weirdness going on.

1 Like

@NoSloppy, thanks I’ll try to remember that trick to pull the post link(s).

As far as catching up, I dunno on either of those possibilities as I only ran the SabertrioOS as intended initially and all my stuff is now switched over to (our?) current OS7. Putting the bmp’s where they belong as per the suggestion I’d received at the time it’s all good. Zero sound ticks happening now and @Fett263’s prop works perfectly.

@Jedemessiah What OS, prop, etc were you running if for nothing more than satisfying the unanswered stuff?