Bluetooth BT630 making me nuts

I can’t imagine 2 BT603 modules are both bad.
I have one in the new saber with a PBv3, seen but not connecting in apps.
I tried a second one on a PBv2 with OS5.7 and still no good.
Tried Forcesync and WebUSB/BLE.
In my config:

added 1 to NUM_BLADES

Added a style to preset. StylePtr()
added this to the BladeConfig:
SimpleBladePtr<CH3LED, NoLED, NoLED, NoLED, bladePowerPin1, -1, -1, -1>()

Wired to 3.3v and LED1, TX->RX RX->TX

Forcesync Android shows the module available, but clicking pops up error

Forcesync iPhone shows the module available, clicking gives me Choose Your Board (and Proffie/TS is really small), but then same error.

Same results with both and TeensySaber Remote app.
Pairing successful, but then loading presets and tracks stalls, and clicking on the CONTROLS buttons just highlights the text .

What am I missing!?

Let me do some testing on the V3 serial port to make sure it’s working as intended.

ok but I have the same results on a v2 board…

Ah, well, that conveniently rules out V3 being the problem.
What style do you have for LED1?
Maybe show the wiring?
I can dig out my BT630 later and make sure things are working for me and see if I can figure out some additional ways to test things.

LED 1 is getting


and the blade for it is setup as blue.
SimpleBladePtr<CH3LED, NoLED, NoLED, NoLED, bladePowerPin1, -1, -1, -1>(),

p.s. the style didn’t show “Blue” when not in back ticks.

It’s a limitation of the forum. I don’t know of a way to turn it off…

I should probably also mention that when I have a problem with serial connections, it’s almost always because I got RX/TX backwards…

1 Like

I wish that were it, but I’ve checked a thousand times it’s 1000% correct. Unless the datasheet pinout and the manuali is incorrect.

I suppose I could try a 3rd proffieboard…

Looks right.
I don’t suppose it works better if the negative wire is hooked up directly to GND?
(Not suggesting that’s as a permanent solution, but it could be a good test.)

same result. error msg in forcesync, hang in WebUSB/BLE.

We found out that these 2 BT630 modules were 2-years old modules with old firmware and old hardware, so better to buy new BT909s.

I flashed them both with the custom saber firmware you provided, same results.

As I say - old hardware. I spent almost a year talking back and forth to Feasycom about the BT630 module issues we had in the past, and they finally fixed everything, they now use newer hardware revision. New BT630 modules will soon be available at TCSS.

That’s fine, but I’m confused how these could have been sold all this time if they don’t work? That doesn’t seem right, as I have seen posts from a long time ago where @profezzorn adapted one to be breadboard friendly, and many others who have used these in builds, all working fine. I just happened to get 2 from a “bad batch” ?

I have the same type of problem with my BT603 module (connect for a few seconds then disconnect…).
is there a way to know if it was an old or a new module?
mine is labeled “Feasycom FSC-BT603 V1.0” and i bougth it 6 month ago.

Really? Could you be specific as to the events that occur?
For me, In the Forcesync App on Android, It sees Feasycom with full signal strength.
Touching that stops the scanning progress bar scrolling at the top of the screen, then it just sits there for a while (This is where the choice of board should be popping up)
Then I get a Connection Lost error message (which isn’t really connection lost, it just can’t talk for some reason)
On iOS, the only difference is that the choice of boards DOES come up, but the Proffieboard white silhouette icon is tiny compared to the others. Then the same error msg popup.

On Forcesync App on android, i can connect, choose the the Proffieboard but a few second after it disconnect…

On WebBLE, i can connect sometimes (1/10), with all working (at least for a couple of minutes), then disconnect :frowning:

but most of time i cannot have control, stuck in loading preset and tracks.

On WebUSB, it always connect and freeze just after a few seconds…

in conclusion, it probably not (only?) a Bluetooth problem, but a serial problem.

(i need to dig a bit more, my last try was with the serial monitor: it freeze after 36s…no more log after, but the saber works perfectly)

11:09:28.118 -> EVENT: Clash millis=745695
11:09:28.118 -> Battery voltage: 4.04
11:09:28.118 -> Battery voltage: 4.04
11:09:28.118 -> Welcome to ProffieOS, type 'help' for more info.
11:09:35.485 -> EVENT: Clash millis=791053
11:09:41.040 -> EVENT: Stab millis=796595
11:09:41.928 -> EVENT: Stab millis=797465
11:09:43.092 -> EVENT: Clash millis=798660
11:09:43.421 -> EVENT: Stab millis=798966
11:09:44.500 -> Battery voltage: 4.04
11:09:45.202 -> EVENT: Clash millis=800774
11:09:46.886 -> EVENT: Power-Pressed#1 millis=802430
11:09:46.886 -> EVENT: Power-Pressed millis=802430
11:09:46.979 -> EVENT: Power-Released#1 millis=802529
11:09:46.979 -> EVENT: Power-Released millis=802529
11:09:46.979 -> EVENT: Power-Shortclick#1 millis=802529
11:09:46.979 -> EVENT: Power-Shortclick millis=802529
11:09:46.979 -> Ignition.
11:09:46.979 -> unit = 0 vol = 0.00, Playing Maul/hum01.wav
11:09:46.979 -> channels: 1 rate: 44100 bits: 16
11:09:46.979 -> unit = 1 vol = 0.50, Playing Maul/out/out03.wav
11:09:46.979 -> channels: 1 rate: 44100 bits: 16
11:09:46.979 -> humstart: 100
11:09:46.979 -> unit = 3 vol = 0.00, Playing Maul/swingl/swingl03.wav
11:09:46.979 -> channels: 1 rate: 44100 bits: 16
11:09:46.979 -> unit = 2 vol = 0.00, Playing Maul/swingh/swingh03.wav
11:09:47.025 -> channels: 1 rate: 44100 bits: 16
11:09:51.464 -> EVENT: Aux-Pressed#1 ON millis=807007
11:09:51.464 -> EVENT: Aux-Pressed ON millis=807007
11:09:51.650 -> EVENT: Aux-Released#1 ON millis=807200
11:09:51.650 -> EVENT: Aux-Released ON millis=807200
11:09:51.650 -> EVENT: Aux-Shortclick#1 ON millis=807200
11:09:51.650 -> EVENT: Aux-Shortclick ON millis=807200
11:09:51.650 -> unit = 1 vol = 0.50, Playing Maul/blst/blst02.wav
11:09:51.650 -> channels: 1 rate: 44100 bits: 16
11:09:55.099 -> EVENT: Power-Pressed#1 ON millis=810673
11:09:55.099 -> EVENT: Power-Pressed ON millis=810673
11:09:55.239 -> EVENT: Power-Released#1 ON millis=810812
11:09:55.239 -> EVENT: Power-Released ON millis=810812
11:09:55.239 -> EVENT: Power-Shortclick#1 ON millis=810812
11:09:55.239 -> unit = 1 vol = 0.50, Playing Maul/in/in01.wav
11:09:55.286 -> channels: 1 rate: 44100 bits: 16
11:09:55.934 -> No sounds found: pstoff
11:09:55.981 -> Amplifier off.
11:09:56.960 -> Unmounting SD Card.
11:10:01.293 -> EVENT: Clash millis=816837
11:10:04.501 -> Battery voltage: 4.03

Serial monitor stopped output?
That’s weird.

For me, WebUSB is always stuck at loading preset and tracks, both phone platforms.
So weird.

@profezzorn ok new info. working with OS 4.9…

That is interesting.
Wonder what the difference is.
I don’t suppose you could do a bisect?