Asking for help with 1st time setup

after struggling and beating my head against my laptops motherboard for hours and days i finally get to where my config compiles, i upload, get this:

c:/users/daddy/appdata/local/arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe:C:\Users\Daddy\AppData\Local\Arduino15\packages\proffieboard\hardware\stm32l4\3.6\variants\STM32L433CC-ProffieboardV2/linker_scripts/STM32L433CC_FLASH.ld:224: warning: memory region `SRAM2’ not declared
Sketch uses 178312 bytes (68%) of program storage space. Maximum is 262144 bytes.
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11

ive went as far as factory resetting my laptop and going through the steps. i reach uploading my config, error pops up. i have no idea how or where to begin to figure this one out. ive seen other posts about this, but i dont have anything else plike controllers and such to cause any conflicts. until i got my lightsaber i thought i was great with electronics and such. this shows me otherwise. i like it, over my head learning something new, just at the limits of what i know to do. thank you for any help its greatly appreciated.

i can post my config text if it would in case its an issue with it.
i dont know what info i need to provide for efficient troubleshooting and assistence. :frowning:

junkyardsaber.h (13.0 KB)

this is my config file. if it posts. beats posting the whole text version unless needed. once again thanks for any help.

See here, your drivers are not correct.

ive run zadig. got nowhere. reset laptop, ran the zadig is dead. same outcome.
reset laptop again, found a proffieboard setup in one of the threads that has the dfu error. i now get the 1-10 countdown. so im making slight headway.
with every attempt and every reset. is there a way of making sure the config would work properly before it uploads? like attempt to run it in a vm or something? also thank you for your work on these boards.

ran zadig. now arduino does not see my proffie board and im back at square one. i dont think i can continue wiping everything everyday follow the how tos and get nowhere. i get told i ran zadig twice. no run once, on to next step. or i run proffie dfu setup instead. how am i now taking steps back?!? im in over my head lol

my pc is now also not seeing the board. it may be a usb/cord/port issue possibly? im putting this old laptop through hell lol

updated display on my devices, it was there. hit upload, got this. im afraid to unplug, but is this a good sign?
File downloaded successfully
Transitioning to dfuMANIFEST state
bell icon says done compiling and done uploading. sorry for all my stupid questions :frowning:

now im getting font directory not found. what? some fonts work. like the smooth fuzz, smooth jedi grey 3rd one. tensy. all the character fonts basically now just dont work. so i have managed to not mess up my saber, i assume. i can flash it. now to get the fonts fixed. how to fix font directory not found.

um, is there a way to take the original .h file open in the os editor on fetts site and add in the edit menus and such or is building from OS from scratch suggested?

also none of the stuuf new os shouldve added, was. whats wrong. im beyond lost

You and me both… way too many posts lost track of what’s going on?

Can’t really help unless we know exactly where you are, did you get the config to upload correctly?

In order to troubleshoot let’s go one step at a time, don’t jump all over the place or it’s confusing to everyone.

If not, what is Arduino currently saying?

If yes, then what is the current issue and post the config you uploaded?

junkyardsaber.h (13.0 KB)

i apologize for the multiple posts. using it as a maintanence log. okay i got the arduino to flash the board. i now have three or four fonts that work out of 25 that came preinstalled. i get font directory not found. and added edit menus do not work. -_- ive done something wrong.

You’re missing the “common” folder with Voice Prompts in your presets (and it needs to be added to your SD card), this is required for my prop and Edit Mode.

Refer to the Set Up Instructions for my prop on this page (scroll down to see all Set Up info):

Also, you’re not using Editable Styles, you’re using very old style syntax so there is nothing to actually edit. You’ll need to generate new styles with editable arguments from my library (the library automatically builds in the editing arguments for you).

Additional info for Edit Mode available here:

i feel rediculous. i have those pages up. been reading. and brain goes. you dont need to download. i apologize. one of those if it was a snake it wouldve bit me situations. okay gonna reread, download, and add files. once again thank you. i really do feel rediculous XD

No worries, you’re learning something new and we’re here to answer questions. Once you’ve got it all down you’ll be an “expert” and be able to help future new users :wink:

1 Like

The only part that can cause major problems is the blades array though. As long as the blades array matches your wiring, the rest is just a matter of tweaking the config file to work the way you want.

Don’t, this stuff is not particularly easy, especially when something doesn’t go right. The best advice I can give is simply to be patient, and when you encounter a problem, take the time to ask for help with as much information as you can. That means writing a detailed description of what you’ve done so far, re-posting your config file every time you change it, and include the full error message, or whatever is getting in your way. The more information we have, the easier and faster it is for us to help you.

1 Like

i believe the actual Proffie sketch and folder i have is old. i downloaded os 7.12 and i have noticed theres a huge difference from the one i have that came on sd card, and one i got from the site. could that potentially be causing issues?

It’s hard to say without knowing what the differences are.

In general, the types of issues you might see from using an older version of ProffieOS are:

  • compile errors (if you’re trying to use newer features in your config file)
  • some buttons or features don’t work as described

If you’re using Fett263s configuration generator, then you almost certainly need the latest ProffieOS for it to compile properly.

is there a sd card font set with those bladestyle codes that is available for newbs to this? im not having luck (at the moment) with the font tool.

are current sabers sent in the updated state or are they sent in a 1.0 type of ordeal hence the need to update? im getting blade style codes from library but im not finding anything for the sd card side. im confused. :confused:

SD cards don’t store blade styles, just sound fonts.
Some sound fonts come with blade styles in text files, but you would need to paste those into the right place in your config file to use them – which is optional.

It’s entirely up to the installer.
Some have a basic configuration that they stick to and it’s basically the same on all sabers. That configuration might be old, but should work.

Some spend hours adding fonts and styles to their installations, tweaking everything to look just right, giving each customer a unique installation. Most people who do this will use the latest version of ProffieOS every time they install a new saber. Of course, if you buy a used saber, the installation is likely to be older, and possibly changed from is original configuration by the user.

There seems to be some question here about how to use the @Fett263 configuration generator as well, but I’m not an expert, so I’ll lett Fett263 answer that.

Regardless of how you generate/edit/copy the config file, you’ll need sound fonts on the SD card, you’ll need to know what directories those sound fonts are in, and the directory names in the config file should match the ones on the sd card, or it’s not going to work.