Weird audio slow motion

Anyone seen this before? (Video below).

Random boots seem to play the sound in slow motion, and also light the blade white-when-off for no apparent reason. Then the next reboot seems fine.

Video breakdown:

  1. First boot might be a little slow - not sure, but blade seems correct;
  2. Second boot definitely wrong - slow audio with random blade lighting;
  3. Third boot I think is correct (Anakin’s scream sounds awful by its nature);
  4. Fourth boot seems good.

OS is 5.9, and I’ve also tried the 7.x from Github. Spec is Bluetooth via LED pad (capacitor fitted between 3.3 volt and ground), 3mm red accent LED, smd blue accent LED, and three sub blade accents inside chassis, one of which is the crystal. So admittedly it’s a busy little install.

Off-camera, after I’d switched from 5.9 to 7.x, I booted it and got a clean boot sound, but when I entered the volume menu, the audio was in slow mo again.

I’ve tried a second SD card, formatted with proper SD formatter, and also removed all the Mac ‘ghost’ files from the SD. Battery is fully charged.

I’m not sure what else to try.

Config is here:

And video is here:

OK, I’ve been fiddling, and I think it may have been a power issue. I was doing the tests with the battery + wire, neopixel connector + wire and positive to charge port wire (which splits and goes to the board) all just twisted hard together so I could leave the extra wire length in case I had to open it up again. Even like that, battery level announcements suggested everything was healthy (4.07 volts) but I’ve now soldered that joint and so far it seems better. Maybe it was an amps or resistance thing? I don’t know.

Anyway I’ll keep testing and report back if things go awry again. I think I’m starting to be a victim of my own caution. I try to test, test, test at every step of every build, so that if there’s an issue I can catch it before it means tearing down a completed install. I’m starting to think that approach may cause more problems than it solves. :confused:

Slow sound tends to be associated with the clock circuit not working. This can sometimes be caused by power problems, but it can also be caused by components touching the clock capacitors. (C7/C8 on the part map):

1 Like

Thanks Prof. That’s good to know. I’ll make a note of that for future reference. (My pile of notes is growing! LOL!).
I’ll double-check when I get home that nothing is touching those clock components, but so far it’s still looking like power was the issue. Fingers crossed that’s all it was.