V3 Power Button No Longer Working

Hello, I just recently received my first hilt with a proffieboard v3 (I think it’s the 3.9 from saber armory), and everything was working fine until I flashed my config. The problem is I didn’t realize at first it was the v3, I thought I was getting a v2, and the only config on the sd card I can open looks like it’s also for a v2. So I built a v2 config and flashed it, and according to arduino it flashed successfully, but I knew something was wrong when I didn’t hear the boot sound you normally get after a successful flash. The saber wouldn’t turn on. So I did a little digging and found out that not only does the v3 board exist now (I’ve been out of the saber loop for a bit unfortunately, trying to dip back in), but it’s also the board on my new hilt. Also the last os I had downloaded was 6.5.

So now I download the new os, build the new v3 config using the v3 site, and everything flashes successfully and everything on the saber seems to work but the power button. I can use fett263 or sa22c’s props and gestures work perfectly and so does the only font I can access, but since the power button doesn’t work I can’t switch fonts or trigger blasts/lockup/etc. I hooked it up to the serial monitor and everything seems to register fine except the button, pressing it doesn’t trigger anything in the monitor. I see the twist on/off events, swings, menu left/right etc. but it doesn’t seem to see the power button at all. I tried 7.8 and 7.7, smallest code and fast in arduino, and even did the boot+reset on the board before reflashing, but nothing seems to work.

Did I fry the button by flashing the v2 config? Or possibly disconnect a wire in the process of flashing? Or is there something I’m completely missing? Any help would be greatly appreciated!

This is the config I’m trying to flash:

This is 1 of 2 configs on the sd card, which I originally based the v2 config off of that I first flashed to the board:

Lastly, I’ve attached the other config from the sd card, which I unfortunately can’t open on windows (looks like it might be a mac file or something). This config had a much more recent last modified date, so I didn’t know if that’s actually the one they flashed before shipping it or not. I can delete it if needed, I just have no way of copying the text out of it, when I try to open it I see gibberish.
._azsaber_config_verndari.h (4 KB)
Thanks again

._azsaber_config_verndari.h is just the invisible resource file for the actual real file.
Is there no version that does not start with the dot underscore?

As far as your power button goes, did you try a different switch or just shorting the pad to GND to see if your hardware is broken?
Does your current button work on a different pad instead?
Software wouldn’t “fry” the pad.

Thanks for the reply! And yeah the regular version that came with the sd card is the one I copied into the “sd card v2 config” pastebin, but obviously that one didn’t work so I went to the v3 one. And unfortunately the board is inside a 3d printed chassis from the manufacturer so I can’t really resolder anything, I might be able to get to it with a multimeter though? Not sure if that would help other than just seeing if a connection’s broken maybe? I was really gentle with it and it worked fine before the failed v2 flash so I don’t think I should’ve broken a connection but doesn’t hurt to check, I just didn’t know if there was anything I was missing in the config or the new os/board with the button or something :confused:

Maaaaaaybe I found the problem? Green and red both show as being connected to the terminals on the button, but it looks like red is on the button pad 2? Is that normal? I’m looking on the site and it looks like that one should be on the other corner using button pad 1. Because button pad 1 shows it uses pins 11 and 12, while 2 uses 13 and 14, and the v3 config is looking at pin 11 for power. Maybe I can just tell it to use the aux button?


Button PowerButton(BUTTON_POWER, auxPin, “pow”);

So it’s a single aux button saber lol XD

There ya go.

1 Like