UW Kylo Crystal Chamber Dims After Few Seconds

Hi all, hoping somebody can help me figure out a weird issue. I recently purchased an Ultimate Works Crossguard(Kylo Ren) during their Black Friday deal. The past couple days I’ve been working on getting the config set up. The config setup hasn’t been an issue and I’ve been able to get new bladestyles and soundsfonts loaded. This isn’t my first proffie lightsaber but it is the first one with a crystal chamber.

The issue: All blades work fine except for the crystal chamber after turning off main blade. The crystal chamber does the off behavior as dictated in the style code for only a few seconds and then goes really dim. This only seems to happen after the main blades have been ignited and turned off. When booting the lightsaber for the first time without igniting the blades, the crystal chamber does the heart beat animation and never goes dim. Seems like turning off the main blades seems to cut power to the leds in the crystal chamber after a few seconds? I can’t figure it out and hoping somebody with more experience can take a look.

Here is my config: KR_UW_DMTv2 - Pastebin.com

I did simple color styles to identify the blades. Here is what I found in case it helps:
130 pixel blade: Main blade
30 pixel blade: 2 side blades. Seems both light on this one declaration
9 pixel blade: Crystal chamber
8 pixel blade: Bottom pummel accent

The 2 other blade declarations I couldn’t figure out at first. However, removing them from the config ends up getting a single blue led to show in the crystal chamber area. So it seems those 2 might be single leds used in the chamber area but not 100% positive as I only see the blue one.

Any thoughts or ideas? Really stumped on this as the style code seems to work fine during initial boot and for a few seconds after blade retraction.

Some of your blade definitions have no power pads. Maybe those are wired directly to GND instead of using a pad? Even so, that’s not what happens if you leave the PowerPINS<> out… Instaed PowerPINS<> defaults to LED1, 2 and 3, which is definitely not going to work without without SHARED_POWER_PINS.

Thanks for taking a look. I noticed that as well. Seems the side blades and crystal blade definitions are the ones missing the powerPins. I got the blade definitions from the Pach Store default config for the lightsaber. The proffieboard wiring isn’t easy to see as it uses the proprietary heart connector and there is a lot of liquid electrical tape on the solder joints.

Is there anyway to figure out the powerpins used without looking at the wiring? Or do you think adding the SHARED_POWER_PINS define might resolve it?

I suppose you could create a configuration that feeds all the data lines (at a dark color, like Rgb<20,20,20> to avoid straining the FETs.) , but only turns on one power line at a time to see what lights up.

Quick update on this. I had an email out to UW for clarity on this from a few days back when I noticed the missing declaration. They responded a few minutes ago and said the side blades along with the crystal chamber had to be combined with the main blade’s power.

Seems like those 2 blades need to be updated with:

PowerPINS<bladePowerPin2, bladePowerPin3, bladePowerPin4>

Then also the #define SHARED_POWER_PINS needs to be added to the config. I’m going to give it a try when I have some free time to see if that resolves the problems. I’ll update once I do incase anybody else that buys the saber has similar issues.

I was able to test a little bit ago and the updated Powerpin declarations seemed to resolve the dimming issue. The Crystal Chamber now honors the off behavior of the blade style. For anybody that has the same UW saber and has this issue, here is the final blade configuration I used:

BladeConfig blades[] = {
 { 0, WS281XBladePtr<130, bladePin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3, bladePowerPin4> >(),
    WS281XBladePtr<30, blade4Pin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3, bladePowerPin4> >(),
    WS281XBladePtr<9, blade3Pin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3, bladePowerPin4> >(),
    WS281XBladePtr<8, blade2Pin, Color8::GRB, PowerPINS<bladePowerPin6> >(),
    SimpleBladePtr<CH1LED, NoLED, NoLED, NoLED, bladePowerPin1, -1, -1, -1>(),
    SimpleBladePtr<CH3LED, NoLED, NoLED, NoLED, bladePowerPin5, -1, -1, -1>(),
   CONFIGARRAY(presets) },

Then I just added the SHARED_POWER_PIN define to the top:


Thanks @profezzorn for helping on this. I really appreciate it.

1 Like

Thanks this helped me!

@profezzorn nice to meet you. I have a question if you dont mind. If you look at his config he has 6 blades. Is there anyway to take up less ram space using this method for standard base blades with audio flicker?

1. StylePtr<MainKyloRenUnstableFilmBasedBaseColor>(),

* StylePtr<SideKyloRenUnstableFilmBasedBaseColor>(),

* StylePtr<CrystalKyloRenUnstableFilmBasedBaseColor>(),

* StylePtr<AccentKyloRenUnstableFilmBasedBaseColor>(),

I imagine these take up less ram space. The quest is how do I get these styles for other blade styles? Without putting in the entire code. Similar to what DMTGAMER did?


Can you share the final config that worked for you?

Thank you MTFBWY

I’m not sure I get it, why do you think these take up less memory?
(I think you mean less FLASH memory, not less RAM memory though, right?)

Here is the final one I used I believe:

Not sure I understand your question but the config I included here has 17 presets I believe and it’s only using about 70-75% flash on a Proffie v2.2. Fett263’s styles, using functions and options allows you to cram a lot more into the configs.