Unusual Compiling Issue?

Arduino: 1.8.19 (Windows Store 1.8.57.0) (Windows 10), Board: "Proffieboard V2, - Pastebin.com here is the error code

I compiled a board today without issue. Minutes later, I try compiling a different config to the same board and got this error. I tried a different board, same error. Different config, same error. Different cord, same error. Then I unplugged the board and hit compile. Same error. Next, I deleted the ProffieOS folder and uninstalled arduino, then re-downloaded clean copies of both and tried to upload the default config. Same error. It seems to be internal, but I don’t know what the issue is. There was no change on my PC that would have reasonably prompted any errors

This is the problem:

C:\Users\Will\AppData\Local\Temp\arduino_build_864282/ProffieOS.ino.elf section .text' will not fit in region FLASH’

Your config has too much stuff in it, and it won’t fit on the board.

I thought so, but it happens with the default_proffieboard config as well. and configs that worked previously

That seems unlikely.
Do you have more than one ProffieOS directory?
Maybe it’s using the wrong one? (or another one than you think anyways)

No other proffie directory (double checked) and still giving an error code with no port selected and default config uploading.

You should remove that screenshot and just copy/paste the error text.

I have seen weird things happen when using OneDrive. Try moving your ProffieOS folder to a local only location. Then again, it looks like your whole Documents folder is also there, so Arduino backend stuff is also cloud…

It’s the same error code. Screenshot was just to show that it’s happening on default config.

Everything is synced to one drive. I’ll try making a new user on the PC and downloading arduino and OS to there as local files

That screenshot is useless, because it doesn’t show the actual error, just one of the warnings. Also, screenshots that convey text are generally not allowed on this forum. (The rule is that if you can use cut-n-paste, then screenshots are not allowed.)

The screenshot was just to show that it’s happening on the default config. It’s the same error as posted above.

Changing to smallest code fixed the issue. It was set to smallest code originally before troubleshooting, so I’m not sure what exactly happened overall, but it’s working now and that’s what matters I suppose! Thanks for the help everyone :slight_smile: