Unable to connect to both MacOS 13.x or Windows 11 (latest)

I have tried multiple MacBooks, multiple PCs, multiple USB ports. Multiple USB cables including the data only cable from Saber Bay (link). I have followed just about every single video on YouTube. Read through countless pages of threads here and Reddit, as well as elsewhere. I have tried the boot/reset. I have tried Zadig about 500 times.

Nothing seems to work. I have tried with multiple profile boards. I have full admin access on every device. I have profiles from Korbanth, 89Sabers (Brand new saber as of today), CCsabers. There is no way all of these boards are just bad. They all work just fine except when trying to connect to a computer of any kind (I have not tried linux but I doubt the OS is the issue.

I have tried with the SD card installed and without. No matter what I do, none of the boards will be detected by any computer.

With the boot/reset I have the USB port pointed downward holding Boot (left side) and pressing Reset (right side) and then releasing then releasing Boot. Nothing happens at all.

When I open Arduino IDE, the only port that shows up on Mac is “/dev/cu.Bluetooth-Incoming-Port”. On windows there is no port at all . Not even in Zadig (latest).

I am a Software Engineer by trade so I am not dumb or incapable of troubleshooting. I understand all of this stuff. It just won’t connect so I feel like I am missing something or there is a secret touch I am missing.

I need some help please.

Short answer: Try a different cable.

Longer answer:

Have you verified that the FPC cable part of that Saber Bay cable is actually inserted all the way into the end piece adapters? Having a cable which made up of multiple parts like that does not make for a particularly reliable cable. If you have room for it where your board is located, I suggest buying an USB-IF certified cable instead.

Micro-usb cables are also notoriously bad. I’ve had people try cable after cable until they had success on the 5th or 6th cable the tried. Granted, some of those cables were charge-only cables.

I’ve order two new cables from different manufacturers both state USB-IF Certified. I do have plenty of 5-pin USB cables. Not sure how many are data capable as we are primarily an Apple house so most anything that uses a 5-pin micro USB is likely only for being charged.

I’ll keep trying but if anyone knows of any specific USB cables I should order, please do share.

Thank you.

Just to check, you’re connecting to the USB port that is physically on the board, opposite the SD, correct? Not a separate USB port on the chassis. There are some installers using USB charging and we’re seeing some users get confused because they’re connecting to the charging port and not the data port physically on the board.

1 Like

Great and reasonable question. No. I am using the 5-pin micro USB port in the proffieboard. Not the MicroSD slot. In fact I have the problem even if the SD card is installed into the board.

I’m plugged into the bottom port that is centered in this image Proffieboard V2.2 | Artekit Labs

Right now I’m looking for links to actual cables that others have purchased that actually work. Please share links.

OK, just wanted to check. I’ve had my cable for years I don’t even recall where I got it. Something like this.

Thanks for the link. I had gone ahead and ordered this one from Amazon. I like yours with the down angled end. But I was finally able to connect. So it was all of my cables that were not working properly.

Cable Matters Braided USB C to Micro USB Cable 6.6 ft (USB Type C to Micro USB Cable) in Black https://a.co/d/4cWOI5e

Now on to figuring out all of this blade style stuff and to update the boards with the latest 7.8 OS (I’ve already backed up the boards in case)