Stumped: 3.9 - Low indicator light, whispers, etc

I’ve spent a good 8 hrs at the bench so far trying to figure this out…

First, the board appeared to flash no problem in it’s factory state. The indicator light was blinking nicely. Upload hit 100%. This board is one of the first batch that came from Tritium/Electronics123 and there stuff has always been great. It’s been waiting for this project in storage.

My wiring diagram is the basic configuration tool one blade set up, and a barrel recharge port.

I went ahead and wired everything up. When I first applied battery power to my new setup, there was a delay, then a quiet boot sound from the first font on the SD card. The blade ignited when the power button was pressed and then everything cut out.

That’s usually a short, so I cleaned and reflowed everything. I did find one spot where they may have been a short on the underside of the board near the FETT2/3 bridge, and I cleaned it up. There was also some solder on the SD card slot, and what appeared to be a tiny bit on one of the underside components (what I think is a resistor right next to ground that connected to BAT (-) ). All of that got carefully removed. Finally I cleaned off the flux. I switched to higher magnification and a smaller soldering tip.

I also made sure the battery was charged, and used a second battery to test. At that point I only got a very faint, constant light from the indicator LED from each battery. No sound.

There was a connector on the battery leads and I removed it, even though I beeped it out with a continuity tester and it was fine, and soldered the battery directly. I also thought I may have made an error with the recharge port, testing and checked the wiring and reflowed the connections.

I then tested for continuity from the rcp to the board and it was good, and appears set up correctly (although for some reason I keep thinking the board line and the bat (-) might be swapped). This was not fun because the RCP is the only bit glued in place. Luckily I used E6000 and not crazy glue.

I then though I’d reflash the board, but it was no longer recognized as a port. Again the indicator light on the board was now a low level, solid green (barely visible). I applied battery power, no change. I tried 2 other cords. Same deal. Finally, I held boot, held reset, released reset, then released boot a few times. The light remained that low green and nothing appeared to change. There are no sounds/beeps.

So I’m stuck and at the limit of my knowledge. All of these remedies in one combo or another have worked in the past. Does anyone have ny suggestions or could point to possible issues?

Thank you!

Typically, a very dim indicator light indicates that the board is in bootloader mode.
Does it show up as “STM32 BOOTLOADER” on your computer?
Does it show up as “STM32 BOOTLOADER” after using BOOT+RESET?
If it doesn’t show up as bootloader, even after using boot+reset, then the board is probably dead. If that is the case de-solder everything and try again. (If it suddenly starts working, then obviously the problem was in the wiring, not the board.)