Some LEDs remain lit after retraction

Hello, I have a neopixel single blade two button saber I built several years ago. It was still on v5.7 and only using the default fonts, and I thought it was a good time to upgrade.

I upgraded to v7.12 and it works well, except for some LEDs remaining lit after retraction. It does shut off after a few seconds. Skip to about 25s to see an example:

example video

It happens on all fonts, not just the original ones. I changed the board include to v2_config.h, for some reason originally I was using the proffieboard_config.h but I have a v2.2 board so switched it to the proffieboard_v2_config.h file.

I have a single 123 LED blade, but also a NOBLADE entry for the 5 LEDs on the connector when just using the plug.

I hope to try reviewing the serial console tomorrow night if time permits. Thanks for any suggestions.


Please post your config so we can take a look.

It looks pretty weird in the video though, because it seems like the audio is also getting cut off prematurely when you turn the saber off. Or maybe that’s just how the font is?

What version of the arduino-proffieboard plugin do you have?

Here’s the config: config

I’m on v3.6.0 of the board package.

From the version I used with v5.7 I changed the board include to v2 and added the new fonts. The issue also occurs on the original default fonts, which is odd. My next steps are to remove the new fonts, and if it still occurs switch back to the v1 board include. And also try to see if the serial console has any clues. I ordered a 90deg USB micro cable because I was having issues getting into that tight space, it should come tomorrow.

But I thought I’d ask in case this is a known issue, maybe a bad config entry.


First of all, welcome!

It’s fine to use the generic config as that simply lets the same config be used on different version boards. If you’d like to specify V2 that’s also fine.

Based on your video, it’s not like a few pixels are remaining on like some other symptoms I’ve seen. It’s your whole animation just freezes.

Does it shut off by itself like that after a few seconds or do you need to kill power?

Regardless, there’s a chance it could just be your SD card giving you a hard time. I would suggest you back up your SD card and give it a nice fresh format using this tool

Copy your sound fonts back onto the card and see how it goes.

Well I see one potential problem, in your config file you have:


But pin 8 is RX, and the same pin cannot be both a serial port and do blade detect. Not sure what this will end up doing.

Thanks, I’ll try disabling serial tonight.

Thanks, will try that also.

It does power off after a few seconds, and then I can power on the blade. It had the feel of the board resetting, but there was no boot sound.

I’m curious about what the serial monitor says when this happens.

Ha, I just grabbed output to see myself. I’ll paste it below. I’ve not resolved it, I’ve tried removing the serial config entry, switching back to the standard board include, not the v2, formatted the SD card and also removed the new fonts and just left the ones from the default SD card image.

I’m still trying to characterize it, but it seemed to work for a bit then started to show the symptoms. I might flash v5.7 again this weekend and see if anything changes. I thought perhaps a short, but then I would expect to happen more than just on the retraction. The battery voltage seems ok.

The blade fully shut off just before the ‘Booster off.’ line.

I2C sleeping…
EVENT: Power-Pressed#1 millis=304453
EVENT: Power-Pressed millis=304453
Motion chip … I2C init…
105 found.
EVENT: Power-Released#1 millis=304660
EVENT: Power-Released millis=304661
EVENT: Power-Shortclick#1 millis=304661
EVENT: Power-Shortclick millis=304661
unit = 0 vol = 0.00, Playing RgueCmdr/hum01.wav
channels: 1 rate: 44100 bits: 16
unit = 1 vol = 0.50, Playing RgueCmdr/out01.wav
channels: 1 rate: 44100 bits: 16
humstart: 100
unit = 2 vol = 0.00, Playing RgueCmdr/swingl06.wav
channels: 1 rate: 44100 bits: 16
unit = 3 vol = 0.00, Playing RgueCmdr/swingh06.wav
channels: 1 rate: 44100 bits: 16
Playing RgueCmdr/swingl06.wav
channels: 1 rate: 44100 bits: 16
Playing RgueCmdr/swingh06.wav
channels: 1 rate: 44100 bits: 16
EVENT: Power-Pressed#1 ON millis=308978
EVENT: Power-Pressed ON millis=308978
EVENT: Power-Released#1 ON millis=309172
EVENT: Power-Released ON millis=309173
EVENT: Power-Shortclick#1 ON millis=309173
unit = 1 vol = 0.50, Playing RgueCmdr/in01.wav
channels: 1 rate: 44100 bits: 16
No sounds found: pstoff
Amplifier off.
Unmounting SD Card.
Booster off.
Battery voltage: 3.82

This serial monitor output looks fairly normal.

I was hoping to see an error or maybe a reset, but nothing jumped out at me. I have guests for a few days and my wife wouldn’t be happy with my turning the saber on and off. :slight_smile: This weekend I’ll try downgrading and then seeing if I can add any additional debugging output. I wonder if I miscounted the number of LEDs, but then I would expect it never to work correctly. I remember when I first put it together I had to reduce the count by one.

One thing I noticed is that the LEDs on the PCB with the pogo pins, when no blade is connected, seem to always work fine.

Worst case I’ll take it all apart and check the wiring, but I’ll wait till I’m completely out of ideas.

Thanks for the help.

That would not cause these problems.

1 Like

I’m fairly certain I’ve isolated this to a hardware issue in the blade itself or the pogo pins, but most likely the former.

I first reverted to my v5.7 build and I noticed a brief artifact before shutting off. Comparing the versions I noticed there is a longer power off delay now. That combined with the basic styles I was using may have hidden this issue.

Then I tried the LengthFinder preset to test each LED pair, and I noticed I was not getting a stable light but several LEDs flickering on and off.

And finally, I set my blade length to 5 and saw the same lingering LEDs, but when I removed the blade and used the 5 LEDs on the hilt PCB, they worked fine. They came on and off as expected.

To me this indicates an issue in the blade itself, perhaps a bad solder joint on the signal wires or a short, though the failure mode doesn’t really match that. It’s been glued together for a while, I’ll need to decide if it’s worth trying to take it apart or just build a new blade. I have have most of the parts for my old K4 Obi-Wan chassis, maybe I should just finish that first.

Thanks for the help and suggestions.

Do you not have another blade to try?

I was just checking tonight, I have some spare parts to make a short blade to test with, I’m going to try that over the weekend.

I seem to have resolved everything, it was a hardware issue. It was either the leads from the board making contact with the bottom of the hilt or the wires were being pinched. When was looking for issues today I carefully pushes the wires into the channel in the top of the of Graflex and then trimmed the leads from the of the board and laid a small piece of electrical tape across the bottom of the board. So far everything is working great.

The wires and board must have shifted when I disassembled it to flash it a few weeks ago. Now I know when upgrading to be more careful about reassembly.

Thanks for all of the help. Now I need start working on a chassis for the K2 saber.

1 Like