SD Cards issues

I just bought a batch of 3 micro SD cards from sandisk, red/grey, A1, 120MB/s, 32GB. none of the cards work in any of my sabers. All have been reformatted on my mac to fat32 system, when placed in a saber, the saber fails to boot, and boots immediately as the sd card is removed. what am I doing wrong with these cards?

Did you use SD Formatter?

I think NoSloppy is on to something.
I think by default Macs will format SD cards using a GPT partition table instead of an MSDOS partition table, and ProffieOS currently does not support GPT partition tables.

Hey, i just tried using SD Card formatted, and still no luck. any other suggestions?

Screenshot 2022-11-09 at 18.58.13
Here’s my sd card format. saber is not reading it and freezes as soon as its inserted, but works fine with other cards.

If the SD card association formatter don’t work, then there must be something about these cards that is incompatible with Proffieboards or ProffieOS. I’m not sure what though. I would need to debug the problem to see what was going on.

Also; the screenshot is not needed, it doesn’t really add anything and it takes up useless space on my server. The rule of the forum says that screenshots are not allowed if cut-n-paste will work. I don’t know if cut-n-paste will work in this particular case though, so I’m not sure if you’re breaking the rules, or just posting unnecessary screenshots.

Wow that’s a really old volume! :wink:

Apologies fredrik, will remember that for future. Could the issue be something to do with these cards being 32GB? or is that not an issue

The size itself shouldn’t be an issue, I’ve tried cards up to 128Gb at least.
I suppose it’s possible that these cards use some new-fangled standard that proffieOS doesn’t support yet, but that seems unlikely.