Saber Unresponsive

This morning I was using my saber and, out of nowhere, it became unresponsive. Changing batteries did nothing, and my computer no longer recognized the board. So, I held the boot and pressed the reset button. Now my computer recognizes it, but even though I’m pushing the OS to the matching COM port, I’m only getting the “1,2,3,4,5,6,7,8,9,10” count in Arduino. Any suggestions on what to do next?

Update:
I’ve tried closing and opening Arduino a few times. I’ve tried different USB ports, and I’ve tried pressing the boot/reset buttons again (this time while plugged into the computer) still just get the 10-count even though I have Proffieboard selected as the port

Does the board show up as “proffieboard”, “STM32 BOOTLOADER” or “unknown device” ?
The last one just means that something is drawing power on the USB port, it doesn’t mean that it’s actually recognized.

More information:

It’s showing up as Proffieboard in Arduino and the system tray

My guess is that the board is crashing/freezing or something.
Could be an SD card problem, so maybe try a different SD card?
If not, I think you need to try the boot+reset thing properly.

  1. Plug the board into the computer.
  2. Hold BOOT, press and release RESET. Release BOOT.
  3. Board should now show up as “STM32 BOOTLOADER”, not “Proffieboard”. (See Start Menu → Control Panel → Devices and Printers)
  4. If the board doesn’t show up as STM32 BOOTLOADER, go back to step 2
  5. At this point the port in arduino does not matter (and shouldn’t actually be shown), just hit upload anyways.

Got it! Those are the steps I followed before, but I must’ve missed something. However, it turns out that the issue was from the SD card. After completely formatting that one and adding everything back and doing the reset and reupload, I had the same issues. Then I thought to delete all of the .ini and .tmp files (except presets.ini) That got it! Just curious: I do have the back ups of those files. Would they be helpful for bug tracking?

Maybe.
Keeping presets.ini when you program the board (using KEEP_SAVEFILES_WHEN_PROGRAMMING) can potentially cause issues, but it’s not support to freeze/crash the board, so it might be worth tracking down exactly what is causing that. I would need both the ini files, and the config file that causes the problem though. (And I would probably want you to try putting those files back on the SD card to see if the problem re-occurs. If not, there is really very little point in me trying to re-create the problem on my side.)

If I recall, presets.ini can freeze the board if there are presets removed from the upload. If the presets.ini expects 9 builtin styles but there’s only 8, I think it freezes everything up.

It’s one of the caveats I covered in the wiki.

Just to clarify, presets.ini is the only file I kept. (I kept it because I have made a number of edits) It was one of the others causing the issue. Also, I hadn’t made any edits recently. I was swinging the saber around and going through my fonts when it crashed for some reason

Might be a problem that is already solved by how save files are handled in ProffieOS7.
If you put the file back, does the problem come back too? (If so, could you post or attach the file?)

Sure thing. I’ll try it out tomorrow

After a long delay, I finally got back around to investigating this further. I don’t know what might’ve caused it, or if it’s worth looking into further, but somehow the curstate.ini was off. The “preset” value in that file was set to “-1”. It happened while I was on my first preset. I tried to go back one preset (which should have rolled back to my last preset) and that’s when it froze up. It hasn’t happened to me before and it hasn’t happened to me since then, so I don’t know how prevalent the issue may be.

Interesting and weird.
I’ll take a gander at the code and see if I can figure out what might cause that.

1 Like