Saber Stops Responding, Only Light Stays On

Not sure if this is related to my proffieboard but every once in a while randomly my saber’s sound and button functionality will stop working. Only the light stays on.

Config and battery are all good. And it’s not the saber on mute (which I know is double tap on pwr). Again buttons stop working and the only way to fix is turn the kill key off and on again.


What happens to the sound when this happens?
Does the lights still animate in any way?
How often does it happen?
What prop are you using?
What does your config file look like?
Does the serial monitor say anything interesting?

1 Like

Sounds cut outs and buttons stop functioning.
Lights stay the same.
Every once in a while. Theme seems to be if I’m hitting the hilt for a clash or swinging it harder around.
Prop and config are good. I use the same ones for a couple of my other hilts.
Haven’t tried the serial monitor.

Someone told me it could be the physical SD card. I went out and got a new one so going to see if that fixes it. Otherwise, I think it could be a loose wire somewhere.

#1 suspect is SD card for sure. I just fired up an older saber programmed with ProffieOS4.9 and an older, basic SanDisk SD card. Worked fine until I upgraded to current OS and much more heavy-duty bladestyles, which was showing tons of lag when doing multiple blaster deflects for example.
Switched the SD to the fast ones I like and it went right away, performing snappy as expected.
Unfortunately, there’s been an issue with some Kingston cards not performing to spec, and bad batches / chip shortage / fake chips / knockoffs problems may have trickled into their product line.

There are a lot of possibilities here.
Since there is no squee-of-death, we can pretty much rule out software crashing being the reason, so… that leaves:

  1. power problems. This could be a loose wire, weak battery or a protection circuit issue.
  2. SD card issues, like too slow, corrupt or worn out

It could also be something as simple as the SD card springs not touching the SD card wiggling a bit when you clash the hilt.

Okay, thank you! I’ll try the SD first. I’m trying to rule that out before I send it back to my installer for a review/fix.