Saber randomly not recognized anymore when connecting to USB

Hey folks.
Ive tried researching this on my own and also following up on some post on here.
So straight to the point. My Sabertrio using Proffie V2.2 that i recently got will not get recognition from my pc when plugging in. No “windows” sound and no memory card window popping up. All i have is my saber making the noise. Mind you, Ive uploaded plenty of times since having it and to my knowledge i “was” going to change my config and upload until this happened, as far as i know ive done nothing different.
Also saber otherwise still works fine. Just wont do anything when plugged in as it usually did, even 3 or 4 days ago. Again after that upload to now, saber works fine.

I have tried boot/reset and upload anyways…i get the 1-10 countdown. Ok ive also looked in devices/printers when the saber is plugged in and after boot/reset. I dont see proffieboard, STM32 anything. I dont see anything in device manager either…sigh

Ive really been racking my brain over this and hoping im just blind to the simple solution.
The only thing i may try tomorrow is go to bestbuy and buy another “Data” cable. Im using the one supplied with my sabertrio order thats done fine thus far.

All arduino settings are still as they should be (currently on os6.5) from 5.9 that came on the saber.

Also, my SD card reader and backup flashdrive all work instantly in this pc in all USB.

Any ideas from what ive stated? If you need more info which you probably do, im happy to describe or provide anything. Reallly just wanting this back to normal, please help!?

Most likely it’s the cable. Micro-usb cables have a fairly short half-life unfortunately.

Gotcha. I was thinking that would be the easiest thing to try and stop overthinking. I assumed being my saber still works and cycles fonts/styles and everything else that its not damaged. Only thing it pointed to was the cable. I will buy one tomorrow and reply back. Big fingers crossed that this is all it is. Id only used the cable maybe 15 times tbh. Thanks for the reply.

only note i may have forgotten to mention, while minor, it does make the noise on the saber end when connecting each time to pc but thats all.

Assuming that happens when there’s no battery power applied, that only means the power part of the cable is intact enough to supply the board, so it boots.

You’re assuming correct. Battery is in the chassis but the kill switch is cutting the power. I’ve never had power supplied in fear of damaging something while uploadimg. But makes sense. I am buying a new cord today. Hoping that’s all haha. Getting something a little more rigid, no offense to S3, the cable is very flemsy.

Thanks guys. Cables came in today, had to order…and instantly worked. Sabertrio even wants to reimburse me lol only a few backs but hey. Just glad that’s all it was. Cheers.