Proffieboard will not connect to computer!

Hello. I am new to proffieboard and I have recently purchased a used v2.2 along with a hilt off of CCSabers. I have followed all of Fredrik’s instructions successfully for proffieOS except I am unable to connect the board to my computer. I have used Zadig and “proffie-dfu-setup.exe” to connect the board but neither have worked. I have put the board into boot mode for both and have tried it on two seprate laptops with no success. Any help is apreciated!

When you say you cannot connect, what do you mean?

Can you not upload? When in bootloader mode the board won’t appear at all besides in device manager. However, uploads will still work.

Can you please describe the exact issue you’re facing?

My board isn’t showing up in device manager on both of the computers I tried.

I’ve preformed all the steps in this video multiple times on two diffrent computers, as well as using the “proffie-dfu-setup-exe”

Are you looking in the correct location under COM & LPT? The board does not show up as a USB device.

Additionally, if you properly used Zadig, the board must have been connected to appear.

Additionally, additionally, have you tried just uploading? Whether it shows up or not (or rather, whether you can find it or not) is kind of irrelevant unless the functionality of uploading isn’t working…

If the board doesn’t show up in Arduino, that’s fine. Reboot into bootloader mode (hold BOOT, press RESET, release BOOT) and try uploading anyways.

Well in the video the STM32 BOOTLOADER Device appears in Zadig when all devices are listed - no need to look under COM or LPT. As I said, I follwed these steps to a T so, yes the board is connected. I would not expect to see the device if it was not connected. Finally, the upload looks like it completes but

I see, then there was some misunderstanding in communication it seems.

If it’s not showing up at all, have you tried different USB cables and/or used one that is known to work for data transfer?

The proffie dfu setup application will work even without the board connected and Zadig is outdated, so frankly to me it seems you’re getting caught up in something that doesn’t matter.

I would try continuing through and setting up Arduino, and take a look at the official documentation… a 3 minute video, an outdated one at that, probably won’t be much help.

If you setup Arduino (or you seem to be talking about uploading there at the end of your message… do you already have it set up? To be honest I’m confused where you’re stuck at), then I’d want to know where you’re stuck, and if it’s a connection thing, try a different cable.

Thanks. I will definitely try a better usb data cable tomorrow. Yes my last message was incomplete and I meant to say that the project compliles and Arduino returns a message indicating that the upload completes, but this happens even when there is no physical board connected. It’s also pretty clear that the upload does not complete because the saber throws font directory errors even though my config file and font folders match. Thanks again and hopefully I’ll have this figured out tomorrow.

Gotcha, let us know how that goes!

When the upload fails due to not being able to connect, you should see a countdown (or up, depending on the platform) from 10 and a FAIL message.