Proffieboard Web Programmer Stuck(

It seems that I’m just unable to compile my config using the Web Programmer. I’m not sure if this is an issue with my config, my machine, or the web service.

I’m using this default config created with the generator: Lazer Cere Config 01-10-2024 -

I ran Zadig and installed the suggested driver and I’m attempting to upload this config using Arduino IDE. I don’t see “Proffieboard Tools” as an option in Arduino but compling my sketch returns the error:

"Error: 1d returned 1 exit status

Exit status 1

Compilation error: exit status 1"

I can’t use RebootDFU through Serial Monitor in IDE either as while I can get it to recognize the board as a COM# (proffie…) after selecting it and trying to send a command it gives me a “Not Connected” error.

After this I attempted to use the Web Programmer to upload a config where I excised the crystal chamber pixel and this began to compile but also got stuck on the “Please wait, compiling…” and never progressed after at least 20minutes.

I’m really at a loss for how to troubleshoot this. Any advice would be appreciated. I’m worried that something may be wrong with the board itself but I’m not experienced enough to understand what the malfunction could be.

If it makes any difference my board appears to be brand new as it is labeled as “PB 3.9” from Korbanth Sabers.

Did you make sure to install the proffieboard arduino plugin and select the correct board?

I believe I am using it properly. I updated IDE and installed the Proffie plugin. Im using the Proffie board manager and I’m making sure it’s recognizing the board. I tried again with the web programmer and I can get it to see the board and begin compiling but it just stalls there.

If it helps IDE will find the board and Serial Monitor will give me a Welcome readout but any attempt to send a command renders the board undetectable.

Can you share the complete error output from arduino when attempting to compile?

EDIT: Btw, your board is most likely fine.

c:/users/joshu/appdata/local/arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe:C:\Users\joshu\AppData\Local\Arduino15\packages\proffieboard\hardware\stm32l4\3.6\variants\STM32L452RE-ProffieboardV3/linker_scripts/STM32L452RE_FLASH.ld:224: warning: memory region SRAM2' not declared c:/users/joshu/appdata/local/arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/../lib/gcc/arm-none-eabi/9.3.1/../../../../arm-none-eabi/bin/ld.exe: C:\Users\joshu\AppData\Local\Temp\ProffieBoard_CERE-Config_TEST.ino.elf.u2anIx.ltrans0.ltrans.o: in function main’:
C:\Users\joshu\AppData\Local\Arduino15\packages\proffieboard\hardware\stm32l4\3.6\cores\stm32l4/main.cpp:129: undefined reference to setup' c:/users/joshu/appdata/local/arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/../lib/gcc/arm-none-eabi/9.3.1/../../../../arm-none-eabi/bin/ld.exe: C:\Users\joshu\AppData\Local\Arduino15\packages\proffieboard\hardware\stm32l4\3.6\cores\stm32l4/main.cpp:133: undefined reference to loop’
collect2.exe: error: ld returned 1 exit status

exit status 1

Compilation error: exit status 1

This reads as though you’ve changed the name of something you shouldn’t have… ProffieOS.ino shouldn’t be renamed.

Ideally, download a clean copy of ProffieOS, copy in your config .h file, and then change the line inside of ProffieOS.ino, don’t rename anything.

Thank you very much, that appears to have cleared everything up.

1 Like

Excellent! Glad I was able to help, happy sabering :stuck_out_tongue: