Proffieboard v2.2 constant reboot

I have a past install I am looking over. On removal of the kill key, the saber boots up repeatedly and gets very hot.

I tested the battery, its at a full charge and gives a strong 4.01v through the multimeter.

The board was recognized originally by the arduino app but after trying to flash a config, the board disappears from the port. I tried putting it into safe/bootloader mode with no luck of that working. The app counts to 10 and ends with FAIL.

wondering if these symptoms are signs of a toasted board?

For clarification, when you say the saber gets very hot, do you mean that the saber itself is very hot or just the ProffieBoard gets very hot?

I know (from experience sadly) that a hot board generally means a short or other electrical problem in the wiring. People that know more than me will ask what part of the Proffie is getting hot; that can help isolate the issue.

It’s just the proffieboard that gets hot. This saber worked for at least a year and has seen two owners. Its possible it could have been plugged into the computer while it was being powered from the battery but I have no way of knowing that obviously haha.

The whole board gets hot.

That is safe. In fact, it may be safer than plugging it in without having it powered by the battery.

Whenever things get hot, there is a short somewhere.
If you’re lucky, it’s something fixable. If you’re unlucky, the short is inside the CPU itself, and the board will never be the same again.

Thank you for the response. I have torn the saber apart and found no shorts inside. swapped components and believe strongly its the CPU as you say. Unfortunate. Only one components left to replace.

I would give the board a nice IPA bath and a healthy flow of compressed air.
See if it doesn’t clean up some unseen debris causing the short.

1 Like

ill definitely try that! I have it all cleaned up and placed to the side for the time being.

Spitballing here, possible stuck (damaged) Boot or Reset button(s)?

If boot was stuck, then it would reboot into STM32 BOOTLOADER.
If reset was stuck, then it wouldn’t boot at all.

The board doesn’t appear to be damaged in any way… visually. The reset and boot buttons work fine.
I had the board wired up to an external battery and a speaker separate from the original installed hilt and once I flipped the kill switch, the board would heat up and repeat the boot up file.
This action actually sped up the longer you let it go.

Can you post a video or something?
I’m wondering if there is an action the board is doing that makes it reboot, or if it’s just overheating or something.

Can you tell which part of the board gets hot?
Have you tried a different SD card?