proffieboard/STML Bootloader not appearing

Hi all,
I apologise if this topic has been raised already but I couldnt find exactly my situation!
wired up my board in my chassis - all seemed to go fine.

Plugged it in to my pc and I just cannot get it to show in my devices, Arduino doesn’t detect the board on a port. I have tried multiple cables, multiple USB ports, even tried on my wifes laptop! have tried the button dance multiple times but nothing.

I have Zadig - but the right device isn’t showing in the drop down so I can update drivers

when i power the board up with battery or cable I get the “directory not found, SD card not found” message from my speaker…so i feel the board is working / not fried!

anything else I can/should try?

I would suggest try running proffie-dfu-setup instead of Zadig.

Also, give this a watch:

First of all, try it with an SD card. There are cases where windows will drop the device quickly because of a board crash without an sd card.

Second, check that the cables you have actually can transmit data. There are lots of charge-only cables around. If you don’t know, I suggest buying an USB-IF certified cable from amazon, doesn’t cost a lot extra. Also, micro-usb cables tend to break easily, so sometimes “good” cables don’t work either. (The record so far is someone who had it work on the fifth cable AFAIK.)

Third, make sure you’re doing the boot-reset thing correctly. When it works, you will not hear the “not found” messages.

If nothing works, it’s likely that the USB circuitry in the CPU is fried. This is unusual, but it can happen. Do you have warranty on the board? You may need it.

Thanks for the super fast replies!

The dfu driver didn’t seem to do anything, still not recognised. I have watched Proffezorn video two or three times and I can’t really use any of the solutions as the device literally doesn’t show up anywhere for me to uninstall/reinstall drivers.

I will order a new cable just to rule that out. And maybe I need to test another proffie to rule out that as the issue!

I have had a close look at the board. I think I have some solder connecting from an LED negative to the Q3 component legs. So I have potentially shorted/fried it here?….i read I can resolder that to one of the other LED pads…but would that also cause these USB problems?

I recommend ordering an USB-IF certified cable.

That seems fairly unlikely.
Sometimes weird stuff happens when you short things though, so can’t say with 100% certainty that it won’t cause this problem.