Proffieboard not responding at all

So I received a Proffieboard from Saberbay today and proceeded to install a hilt. Upon completion I immediately noticed the sound was working except for the hum and smooth swing. Everything else worked fine including LED’s and other sounds. I tested the config on other savers of mine and they worked fine. Is it something I did with the install? Or maybe the software? I am using an older version of ProffieOS but I can’t imagine that would affect it if it works with my others right?

I should further add, later on, nothing was changed but the board completely stopped working. No power, nothing. Plug it to the charger, nothing, plug it into the computer, nothing. Not sure what I did wrong but almost everything was working fine

Usually when everything works except hum/smoothswing, it’s a problem with the motion chip.
What version of proffieos are you using?
What does the serial monitor say?

I believe it is 5.7 or whatever was the newest before 6

5.7 has problems.
Please try 5.9 and 6.7 and see if they work better for you.