ProffieBoard not recognized by windows

Hi, I know you’ve all seen this before but im still unable to find a solution

My proffieboard is not recognized by windows, i have tried several different cable and still no progress

changed power plan options, flashed the board using the buttons several times and i still receive unkown usb device in Zadig.

Losing my mind trying to get this thing to recognize, installing the driver in Zadig fails and i have no other options to try.

The error is that USB device is not recognized by windows and Zadig sees that it has no driver.

I’m a bit confused by this description.
Do you see an “STM32 BOOTLOADER” device?
If not, there are only so many possible explanations:

  1. bad cable (note that I have sen users try 4-5 games before finding one that works)
  2. bad usb port
  3. Didn’t do the BOOT+RESET correctly (hold BOOT, press and release RESET, release BOOT)
  4. broken board

Usually, once 1-3 has been tested enough, (4) becomes the only possible conclusion.

Hi, i’ve tried multiple different cables, maybe 10 that’re all data. I see no STM32Bootloader.
Tried every port on my PC, a friends pc and also a seperate laptop, tried win11-win10 and win7.
The boot+reset process i am sure i have done correctly, the board is still visible in windows but listed as device descriptor not found. The board does not make the sound after pressing both buttons and stops disconnecting and reconnecting through the usb port.
I have also tried 2 completely different proffieboards and the exact same symptoms. These boards were bought at the same time and purchased from padawan outpost. If i can’t find the solution today then i will return the boards and ask them to replace or test to see if it works on their machines. Please let me know if you have any other suggestions and thanks for your response :slight_smile:

If the bootloader won’t show up on the computer with BOOT+RESET, then something is definitely wrong. Once cables, usb ports, computers and “pressing boot + reset wrong” has been eliminated, then the only possible conclusion must be that the board(s) are broken. So yes, it would seem that these boards are indeed broken and should be returned/replaced.

Okay great, thanks for your response. I’ll try to get them replaced by padwanoutpost!

@profezzorn Hey, just to let you know i’ve found a solution. Its a darkwolf/lgtsabers board. Cannot fathom why this isn’t known or detailed anywhere but the tiny chip that is in the photo linked is what was apparently causing the problem. After removing, the issue is gone.

Just got the same suggestion from padawan outpost. How did you remove it and what is this chip for? Has to be there for a reason or not?

No clue on its purpose, padawan said that i can still return it if i wanted to as they instructed me to do it, i just got my alan key and very carefully popped it off

That was tense. :fearful:
But it really worked. :slight_smile:


So…you guys are

  1. being instructed by the retailer to remove the ESD protection chip and
  2. you’re removing it by force by jamming an allen key at it and
  3. that is solving the “not recognized by Windows” problem?


Yeah, “WTF?” was also my first reaction. But after Rblake confirmed it, I thought why not, lets give it a try. Padawan Outpost assured me that they still would honor the warranty.

And now we know that it was the chip was for. Does it protect the board or the usb port from ESD?

It protects the board from ESD through the USB port. Therefore it is there for a reason and while the board will operate without it (see the Crimson Dawn shipping without U40 chip debacle), obviously it is not ideal.
@profezzorn would be the one to explain the correlation (if any, because it makes zero sense to me) how the presence or absence of that chip could possibly affect the host computer’s ability to correctly identify the device.

I had the retailer guarantee so i thought why not experiment what they requested, incredibly surprised it worked.

So, if that chip is broken, installed backwards, or someone just put the wrong chip on there, then USB wouldn’t work properly. I don’t see how such a board would pass testing though. Makes me wonder if they are selling untested boards?

I guess with the chip craziness going on, fake or bad quality chips is not an impossibility.
Untested is another question.
Encouraging people to pop off U40s as a workaround it’s just unacceptable in my opinion.

1 Like

The man behind Electronics 123, Tanner Ewing shared this bit from behind the scenes as a manufacturer of Proffieboards:
“I can shed some light on this. The manufacturer of the ESD chip had a batch of chips go out that were incorrectly labeled in the Chinese market. It was several million chips. These chips ended up being installed on some proffieboards and they do not function with them. The boards will NOT pass QC using Fredrik Hubinette’s testing fixture with the incorrect chip because it shorts out the usb connections. This means that the manufacturer is not testing the boards if they are arriving with the bad esd chip. It is very easy to get the wrong chip when buying parts from the Chinese market, or when building product in China.”

Hi, Hammer. I also have a saber from PO that has all the same issues. How did your situation get resolved? Did they send you a properly working replacement core? I also tried resetting the board, and you could hear it “chime” on the PC, but still would not show the Bootloader on my PC. PO has sent me 2 new cores with same problem, and same thing when I tried resetting the boards. PO recently sent me an email saying that they checked the replacement core on their MAC before sending it out and it worked properly, so it must be something on my end. I own 3 other sabers (1 that I bought form PO) that I purchased last year that have no issues, so not sure how the issue is on my end. They say they do not offer tech support and I can get a refund but they have done everything they can. I contacted another official seller of LGT sabers, discussed my problem (without naming where I got it from), and they replied that bad chips went to PO and there should be no problems getting them replaced. Trying to figure out if they are short-shrifting me because they are busy moving into their new warehouse, or if they are shafting all of their customers who got the bad boards.

Hi Steeler_Nation,

I did send the core back but opted for another item as a replacement instead of a new core (xenopixel “lego” hilt, really liked the design and in the meantime I also received my S3 Proffie Senza, so no need for the LGT core). So I can´t really give you any helpful information regarding your trouble with PO. All I can say is that my faulty core problem was handled smoothly and to my satisfaction.

1 Like

I have a similar issue with 2 proffies…

Windows will not see the boards any COM port. But i do see the bootloader in windows devices and I can program the board. After that I, i still cannot see the com port and the usb driver never shows, but the board works…

Is this the same issue?