Proffieboard not recognized by computer

Hi, I’m new to this forum and to Proffieboards. I just got my first proffie lightsaber (version 2.2) about a week ago and have been trying to load some new sound fonts onto it. However, my computer does not recognize the board. When I go into the device manager it says there are no drives installed, so when I’ve tried some of the fixes listed online, they’ve been unhelpful. For some context, I’ve gone online and watched several youtube videos on how to use Proffie OS. I’ve downloaded Arduino, gotten the plugin URL loaded in, and even downloaded Zadig. I get stuck on the zadig step as even while doing a reboot on the board, I can’t get the STM32 BOOTLOADER to show up. All I can see is "unknown USB device (device descriptor request failed). I’m on a windows 10 PC. Troubleshooting on the PC has also resulted in nothing. Any help would be appreciated! I hope I’m just missing something little that will get me rolling. Thanks!

There were some updates, and zadig is the older way of doing things. Did you try installing proffie-dfu-setup?

The newest basic instructions are here:


I didn’t realize there was a newer way of doing things. I just tried installing proffie-dfu-setup and nothing has changed. Was there something else I needed to do? My proffieboard is still showing up as having no driver associated with it and it’s still showing as an unknown USB device. Part of my issue is that because it’s an unknown USB device, I can’t set up a port within Arduino.

In windows “unknown USB device” usually means that windows cannot talk to the device. In the vast majority of cases, this is caused by a bad USB cable.

There are other possibilities:

  1. The board is bad
  2. You have a bad programming, causing the board to crash AND you don’t know how to use BOOT+RESET to to get it into bootloader mode.
  3. Something is wrong with your computer.
1 Like

Hmm…well that would be a bummer. I just bought a brand new usb just for this purpose so it should be good. I have tried the boot and reset method as I saw that as a troubleshooting method several times. All it’s done is just play the intro to the first sound font on the sd card. I also just got the lightsaber and the sound fonts the manufacturer put on work, it just wont be recognized by my computer and troubleshooting through windows results in nothing. I’ll try another usb. I’ve only tried 2 so far. Could there be something stupid I’m doing? I’ve tried with the battery and SD cards in, with the battery out, and even with the battery and SD card out. Thanks for your input!

Just remembered this, but not sure if it would be relevant - the first USB cable I tried worked for like 1 minute, but then stopped and hasn’t worked again since which is why I bought a brand new usb. Makes me wonder if it’s my computer then? Maybe my firewall or something like that? Is that something that can happen?

If you ran it and it completed, what has changed may not be visible; the driver for STM32 BOOTLOADER was installed to the PC.

Well that means you didn’t do it right and you simply rebooted the board into ProffieOS. You need to release RESET before releasing BOOT.
You shouldn’t hear anything from the board, and you just hit Upload in Arduino (regardless of the Proffieboard not showing up in menu Tools>Port)


Thank you all for your help! My computer now recognizes the proffieboard and I can select a port in Arduino.