Proffieboard giving two 'font directory not found' errors and an 'SD card not found' error


I plugged in my proffieboard a week ago to flash some new sound fonts and changed a few config files, such as the buttons. When I uploaded this, suddenly the board was in an unrecognisable format for my computer, and one reset later I got three errors back-to-back and I have no idea what went wrong. I’m even running the newest OS in case that would help me but nada.

So, typically this happens when you fail to “remove safely” before unplugging or programming. What you’ll want to do is to format the sd card and put all the files back from a backup. If you take the sd card out and put it in an SD card reader, it will go much faster.

If you’re not sure if you have all the files or not, I suggest using a new SD card instead, that way, you can always try to rescue files from the current sd card at some point later.

Tried that, all of the folders are on there that were on the original SD card.

Unless… was there a hidden folder for some reason? And, if not, is there a proper format thing to use (FAT32 or something IDK)?

Well, if it’s saying “SD card not found”, it might not be formatted correctly. For instance, it may be using a GPT partition table rather than an MBR partition table. I recommend using the sd association formatter, not because it’s the best but because it always formats the card in a way that ProffieOS can read. :slight_smile:

OK. That worked, but now it randomly activates without anyone nearby.

What does the serial monitor say when this happens?
What version of ProffieOS are you using?
Also, post your config file so we can take a look.

I don’t know how to check the serial monitor, I’m using 6.9 (I think), and the config is attached.

default.h (42.1 KB)

Here is how to check the serial monitor:

I do need to charge it first so I’ll see if it still does it.

Yeah it’s still going. I have it plugged into my laptop but I always take the battery out which might have an effect.

No dice. It didn’t turn on while plugged in. Did you see anything in the config? I’ve been using it for ages and I’ve had no problem before.

Not sure if this helps but I had the same issue the other day and turned out to be a grounding issue. Maybe something came loose?