Proffieboard causing SD cards to be corrupted?

I’ve tried 3 different SD cards (PNY, Sandisk, Patriot). It’ll run fine for a few spells but eventually the “SD Card Not Found” message plays on boot. I’ll put it in the PC and it’ll show the SD card is corrupted which I then reformat and put everything back in, and then the cycle continues. Now though, the last card I put in (which has worked fine on another install) is completely “unformatted”, aka every PC/Mac I have now says it’s a non-formatted disk and any attempts to format it now gives the “Cannot format: Disk is write protected”. Thoughts?

Try latest ProffieOS from github and see if that helps.

1 Like

Referring to 6.7? That’s the one on all my boards including the one that’s been corrupting SD cards.

Also all 2.2 boards.

No, I mean the latest git master, which doesn’t really have a number yet, but it’s going to become ProffieOS 7.x soon.

1 Like

Ah ok. I’ll give it a try once I get some replacement SD cards in.

This is super weird, but there has to be a way to unprotect it, right?
Did you try the SD association formatter?

Tried the SD association formatter, went into CMD to try to remove, registry edit. No dice. Disk management just shows as Raw format.

Update: Tried to put the sd card (with adapter) in my Nikon D850 since that sometimes overwrites write protection to format. Nada. It’s very strange.

Is there a link to this matter for the soon to be 7.x os?

Not sure how to interpret this question exactly.
The only link I’m aware of is that a few people have reported that the new config saving code in ProffieOS 7.x seems to fix the issue for them.

So far knocks on wood haven’t seen an SD card corruption though the new 7.x does take up more memory (knocking out 1 bladestyle).